Remote control working intermittently

If it’s losing signal – then it makes sense to re-pair it

  • Remove the USB from Vero 4K / Pi
  • Hold Home and OK button for 5 seconds or so, then the blue LED will keep flashing.
  • Plug in the USB receiver and the LED should flash 3 times after 5 seconds, indicating successful pairing.
  • Power off Vero 4K / Pi for 2 minutes. Turn it back on. The remote should now work.
1 Like

This seems to be a problem with the dongle. I tried another RF remote control and it works fine. I don’t see it in the store, so I suppose it’s not possible to order just a replacement for the dongle? Not really about the money, but I already have two remotes + zero working dongles so it seems a bit silly to order another new remote and end up with 3 remotes + 1 dongle!

Does this remote have volume buttons?

Your device is probably out of warranty; but it doesn’t matter. I’d be happy to send you a new dongle in the post free of charge. Unfortunately we haven’t been producing dongles for the old remote (no volume buttons) for some time. I have given all of the dongles that we have away as out of warranty replacements.


I appreciate the offer - the remotes are both old ones; and it’s definitely out of warranty (I think about 1.5 years old now). I’ll just order another one & retire the old ones!

(… ordered… thanks for having such reasonable international shipping rates!)

Had this issue happen again…

Once it hung up, i started mashing buttons and then looked for the blue light. I saw it blink once, then it wouldn’t blink anymore… I tried doing the home + OK button, but didn’t get any blue light…

I had to remove the battery from the remote for it to recover, then I put the USB dongle back in and it’s working again… It seems like the remote is crashing, so what’s the fix for that?

I’ve received 3 devices back over the last month. Normally we get two every 3-4 months.

All units were simply afflicted by a low battery. So before proceeding, let’s check the obvious causes.

Have you changed the battery? If so: is it new?

Sorry if this sounds obvious, but we have lately become a battery replacement service


I can test changing it, however why does yanking the battery cause it to work again?

You’d think if the battery is dead enough to not work it shouldn’t work ever…

Low batteries behave sporadically.

When I was an avid Xbox player, I used to do all sorts of tricks to get a little bit more life out of my batteries without waiting for a recharge :slight_smile:


Following back up on this… I replaced the battery with a new one and it seemed to work better for a while. However now it’s back to doing the same thing…

Do these remotes eat batteries? Do I have a defective remote that is using more battery than it should? Right now I have to take the battery out and put it back in. Then it works for a while. If it was the battery it shouldn’t work long after I do this process.

A good branded cell will last 6 months or so typically.

If the remote has to hop bands regularly due to interference, this can drastically reduce battery life.