Remote "Double-Clicks" Following April 2019 Update

I have the FLIRC 2. I don’t know how to do the first thing you ask, install usb-utils etc. I’m happy to go back through the upgrade and do what you need if you can post directions.

My remote is a remote used by a satellite TV vendor in the UK but it perfect for media boxes like Kodi / OSMC due to the buttons it contains, when mapped with FLIRC. It does mean however I can’t adjust the repeat time as mentioned a post above.

Remote here for anyone looking for a good option: https://accessories.sky.com/catalogue/products/sky-terabyte-remote-control

ok, I’ve upgraded to the latest release again.
Logged in to the OSMC box via putty and ran:
Sudo apt-get update
Sudo apt-get install usbutils
lsusb

the output is:
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 20a0:0006 Clay Logic
Bus 001 Device 002: ID 0bda:8153 Realtek Semiconductor Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I have 1 USB extender cable + FLIRC 2 plugged in, plus 1 USB > Ethernet adaptor

When I remove the USB extender cable nothing changes on the lsusb output

That’s it.

I try to reproduce the problem, but i am not able to.

my setup:

  • RPi2
  • just installed 2019.04-1 on a fresh SD card
  • FLIRC Gen1 Firmware 3.7.0 (FLIRC software 3.22.2 wants to update to 3.9.00)
  • setup 3 years ago with FLIRC Software 1.4.3 and doing clear config and erase all (no further config)
  • Harmony Elite with profile FLIRC Kodi
  • @DBMandrake in the new config software is a reset to default button and that one sets min repeate rate to 1
  • FLIRC USB id Bus 001 Device 005: ID 20a0:0004 Clay Logic

Should i test something else except updating the FLIRC firmware and see if the new one hast the problem? Does anybody know how to downgrade FLIRC firmware, so that i can go back to 3.7.0, then i will test the latest one.

Edit: Same on my Vero 4k+. I can not reproduce.

@DanOnline @steamship @JJK9 @new_account @darekk @PhilC @dnwhoop02 and anyone else having problems with unwanted repeats after the last update.

We think we’ve identified the cause and a potential fix for this problem. If you want to try the fix ahead of time and give feedback as to whether it fixes it for you please try the following:

Via SSH first install the ir-keytable package:

sudo apt-get update
sudo apt-get install ir-keytable

Next create a udev rule file by creating a new blank file in nano:

sudo nano /etc/udev/rules.d/70-input-repeat.rules

Then copy and paste the following into nano:

ACTION=="add", SUBSYSTEM=="input", KERNEL=="event[0-9]*", GOTO="start"
GOTO="end"
LABEL="start"

# don't change eventlircd device settings
ATTRS{name}=="lircd", GOTO="end"

# don't change settings of rc remotes
SUBSYSTEMS=="rc", GOTO="end"

# set default repeat delay to 500ms like rc remotes
RUN+="/usr/bin/ir-keytable --delay=500 --period=50 --device=$devnode"

LABEL="end"

Save (CTRL-X then Y) then reboot. This should change the repeat delay and repeat rate (period) for any keyboard-like devices including flirc.

The repeat delay and period can be customised by editing this file and rebooting, however I think the suggested default of 500 and 50 should be fairly optimal. Please let us know whether this fixes the problem for you.

(For reference the default OS values before applying this change are 250 ms for the delay and 33 ms for the period, so a much shorter repeat delay and a faster repeat rate)

1 Like

That’ll be why you’re not seeing a problem. I tried increasing my harmony to 3, which started causing the issue on almost every press, but with it set to 0 (my setting) or 1 (your default) I didn’t see a problem.

From what you say it looks like 1 is the default in the new harmony software for new configurations - in the old software it was (years ago when I set up my remote) definitely 2 or 3 as I always found I had to reduce it on most of my devices, not just Flirc.

In any case we found that the new default repeat delay was only 250ms - which IMHO is far too short. This default actually comes from the Linux OS itself, probably in the source code for the keyboard device driver in the kernel, however we can override it as in my previous post.

Even though you’re not having a problem you might want to try the suggested fix to ensure that your remote still works well. (Mine does, both set to 0 or 3) What you should notice after applying the fix is that there is an obvious increase in the delay between when you press the button and it starts repeating, from 250ms to 500ms.

Testing this by pressing and holding up or down on a list of Movies/TV Shows is probably the best way to notice the difference.

Guys…

You’ve nailed it with the above. Perfect and back to how it was in previous version of Kodi / OSMC.

Many thanks, amazing support as always.

I haven’t updated my libreelec build to Leia yet, as I was worried I’d have the same issue. Can I apply the same fix to them if it has the same key repeat issue?

I’m not familiar with coding in Kodi, so will have to wait for an update, but from the replies already posted, it’s look like you’ve got it sussed. That’s great news.

It’s a 2min job to make the change, you’ll just need to download an application called Putty to log into the OSMC box and apply the change. I’m happy to write a more detailed step by step if you want to have a go at it. It really is easy, even for a novice. I learnt the basics from a few internet searches.

Thanks very much for the offer. You wouldn’t believe it, but I’ve 25+ years in IT experience (all aspects) and the best part of another 10 years prior to that of interest. Personal circumstances changed and now I’ve problems stringing two words together, never mind doing a bit of programming. Since I rely a lot on my Kodi setup, I’d rather not risk screwing it up, so may just wait for the update.

Works perfectly again, thank you so much. OSMC seems to be the most stable version of Kodi on my RPI3 but this issue prevented me from using it.

Thanks for the confirmation that it fixes the problem for you. Out of interest which remote do you use with the flirc, and do you find the repeat speed when held down to be comfortable to use when scrolling in lists ? (eg not too slow and not crazy fast)

I think the plan is to have an update out in a few days that addresses this problem however we have a little bit more testing we want to do with different remotes before then.

This should also resolve the issue with suspend waking up on Vero 4K / 4K + if the repeat presses are causing this.

Sam

I have a [non FLIRC] USB remote that had the key-repeat problem, and this fixed it for me.

Thanks for the swift fix.

I use a One for all Contour 8 universal remote. Link, I cant remember what remote profile it’s using with the Flirc as it was years ago and I just chose a random remote to learn and programmed the buttons into the Flirc app.

I can’t really comment on the scrolling speed when holding the button as it’s never worked properly for me on any version of Kodi using the Flirc, possibly due to the remote i’m using and so I tend to just use the scroll bar to quickly get close to the series/movie im looking for and then use individual clicks on the titles to navigate to the correct one/

You won’t need to. An LE developer (HiassofT) helped us with the solution in their Slack.

Sam

This procedure worked for two of my Vero 4k units, but something wonky about the third one. Same one I never got resolution on many months back with respect to the App store weirdness and SSH - I forget the specifics… Anyway…

Linux KODI-GuestBedroom 3.14.29-143-osmc #1 SMP osmc-ccachefix aarch64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sun Apr 28 17:03:33 2019 from 192.168.168.163
osmc@KODI-GuestBedroom:~$ sudo apt-get update

Ign:1 http://ftp.debian.org/debian stretch InRelease
Hit:3 http://ftp.debian.org/debian stretch-updates InRelease                      
Hit:4 http://ftp.debian.org/debian stretch Release                                
Hit:2 http://ftp.fau.de/osmc/osmc/apt stretch InRelease                           
Hit:6 http://security.debian.org stretch/updates InRelease                        
Reading package lists... Done                                 
osmc@KODI-GuestBedroom:~$ 
osmc@KODI-GuestBedroom:~$ sudo apt-get install ir-keytable
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  armv7-libcrossguid-osmc bluez libapt-inst1.5 libbind9-90 libdbus-1-dev
  libdns100 libdpkg-perl libgif4 libgnutls-deb0-28 libhogweed2 libicu52 libisc95
  libisccc90 libisccfg90 liblwres90 libmicrohttpd10 libmysqlclient18 libnettle4
  libntdb1 libplist2 libpng12-0 libpsl0 libssl1.0.0 libwebp5 libwebpdemux1
  libwebpmux1 libxtables10 pkg-config python-dbus-dev
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  ssh-app-osmc
The following NEW packages will be installed:
  ir-keytable
0 upgraded, 1 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/89.6 kB of archives.
After this operation, 239 kB of additional disk space will be used.
Do you want to continue? [Y/n] y

(Reading database ... 26243 files and directories currently installed.)
Removing ssh-app-osmc (1.2.3) ...
Removing 'diversion of /etc/ssh/sshd_config to /etc/ssh/sshd_config.distributed by ssh-app-osmc'
dpkg-divert: error: rename involves overwriting '/etc/ssh/sshd_config' with
  different file '/etc/ssh/sshd_config.distributed', not allowed
dpkg: error processing package ssh-app-osmc (--remove):
 subprocess installed post-removal script returned error exit status 2
Errors were encountered while processing:
 ssh-app-osmc
E: Sub-process /usr/bin/dpkg returned an error code (1)
osmc@KODI-GuestBedroom:~$

Cheers,
Robert

Your system is not upgrading properly. Had to tell why without full logs; but you may wish to reinstall OSMC as the quickest way to get things working again.

Your fix resolved the issue, thank you!!