Remote "Double-Clicks" Following April 2019 Update

This procedure worked for two of my Vero 4k units, but something wonky about the third one. Same one I never got resolution on many months back with respect to the App store weirdness and SSH - I forget the specifics… Anyway…

Linux KODI-GuestBedroom 3.14.29-143-osmc #1 SMP osmc-ccachefix aarch64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sun Apr 28 17:03:33 2019 from
osmc@KODI-GuestBedroom:~$ sudo apt-get update

Ign:1 stretch InRelease
Hit:3 stretch-updates InRelease                      
Hit:4 stretch Release                                
Hit:2 stretch InRelease                           
Hit:6 stretch/updates InRelease                        
Reading package lists... Done                                 
osmc@KODI-GuestBedroom:~$ sudo apt-get install ir-keytable
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  armv7-libcrossguid-osmc bluez libapt-inst1.5 libbind9-90 libdbus-1-dev
  libdns100 libdpkg-perl libgif4 libgnutls-deb0-28 libhogweed2 libicu52 libisc95
  libisccc90 libisccfg90 liblwres90 libmicrohttpd10 libmysqlclient18 libnettle4
  libntdb1 libplist2 libpng12-0 libpsl0 libssl1.0.0 libwebp5 libwebpdemux1
  libwebpmux1 libxtables10 pkg-config python-dbus-dev
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/89.6 kB of archives.
After this operation, 239 kB of additional disk space will be used.
Do you want to continue? [Y/n] y

(Reading database ... 26243 files and directories currently installed.)
Removing ssh-app-osmc (1.2.3) ...
Removing 'diversion of /etc/ssh/sshd_config to /etc/ssh/sshd_config.distributed by ssh-app-osmc'
dpkg-divert: error: rename involves overwriting '/etc/ssh/sshd_config' with
  different file '/etc/ssh/sshd_config.distributed', not allowed
dpkg: error processing package ssh-app-osmc (--remove):
 subprocess installed post-removal script returned error exit status 2
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)


Your system is not upgrading properly. Had to tell why without full logs; but you may wish to reinstall OSMC as the quickest way to get things working again.

Your fix resolved the issue, thank you!!

We’re just doing final testing of an official update to address this problem which also tidies up remote repeat speed with the osmc remote (speeds it up to match the repeat speed of a flirc receiver and other keyboard-like remote devices) and fixes suspend on the vero4k. (All three problems were related to eventlircd configuration so we ended up fixing them all at once)

All going well this update will probably come out tomorrow.

1 Like

To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Quickest in what sense? The installer is less than intuitive and installation instructions on the wiki seems like haiku.

I’ve got the installer installed on my workstation but it comes up with a different list of versions available every time I run it. Not that it matters, when it comes time to select a destination, all options are greyed out, although I do have a blank USB drive warmed up and ready to receive.


Once the actual fix is released, do we need to back any of this out?

No, these updates will be just overwritten with stable release at that time.
Just suggest as @nazarko wrote to remove the staging repro from your sources.list.

Thanks @sam_nazarko this fixed it for me!

I got this update on my vero 4k (armv7-eventlircd-osmc 1.3.7) and it caused problems with my IR remote (the “repeating keypress” issue), making navigation extremely difficult. Reverting back to version 1.3.4 fixed the issue for me. Does this update require some manual editing of some config file somewhere to go along with it?

What IR remote do you have?

I’m using an Inteset INT-422-3 programmable remote (JP1 remote programed via RemoteMaster), using the Hauppage PVR350 protocal (I created a custom conf to add a number of new codes to handle additional buttons and kodi functions that were not availble in the Hauppage conf that was in /etc/lirc/

I sent an email with the lirc conf and RM upgrade if that helps.

Did you record that profile on the Vero?


[quote=“DBMandrake, post:44, topic:79538, full:true”]All going well this update will probably come out tomorrow.

Did this update get released yet? Reason for asking is that I haven’t been prompted about an update. Having read the comment, I also went into OSMC itself and checked for updates, and none were reported.

No, if it were, you’d be prompted.

I’m not sure what you mean by “record that profile on the Vero” so I am guessing the anwser would be “no”.

I created it by copying the existing config file for hauppage 350 remote and editing it to add some new codes that were missing.

Can confirm that the issue is fixed for my Harmony Bluetooth remote. Though responsiveness of the remote seems a tiny bit slower now.

Do we need to remove or back out the config file that was the original fix for this after the official update is applied? (i.e. back out the instructions in @DBMandrake post.)

Asked and answered by/to yourself a few posts before.

1 Like

I just upgraded to the latest dev version and the issue is still there, just to confirm it is not fixed yet.

I have a FLIRC controller.


creating sudo nano /etc/udev/rules.d/70-input-repeat.rules as documented above sort of fixes the repeat issue but it doesn’t seem quite as good as it was before, it might just be a false impression.

For example a quick press of play works as expected but holding the play button is equal to pressing the info button which brings up the episode or movie info.
I’m pretty sure this is no normal behavior and it didn’t do this before.