Remote fault

The remote for one of my Vero boxes has developed the following fault:

After I boot, all is good for a few clicks. If I access a list and start clicking up (not holding down, just clicking through) all is good for a few clicks and then all goes crazy and I’m caught in a super-speed scroll lock, I lose control and eventually I get a freeze and I can’t resume control without power cycling.

So for now I’m sticking with my TV remote via CEC but I’d prefer to use the Vero remote. Is a log likely to help with something like this? I guess I’ll need to do that remotely as I lose all control of the Vero via the GUI.

I’d assume you can just pull the dongle and that would get you control of Kodi again via CEC. Have you tried another battery? Perhaps you could try removing the battery when it is in this stuck button phase and see if it stops. I think this would tell us if the issue is in the remote or the dongle. If it is in the remote then you might be able to take it apart and clean it. I’m assuming this is a remote that is a number of years old now and out of warranty.

I had tried a voltage test on the battery and it’s good. I’ll see if I can open the remote to clean it internally.

Logs would be useful.

Did you try re-pairing by holding Home and OK?

I tried the Home+OK re-pair, not sure if I did it right but no joy. Here is a log from a session where the scrolling shifted to runaway-train mode, eventually I was able to recover using the Kodi remote app on my iPad. I tried fast-click scrolling via the app and all was good. I wonder if the physical remote simply has worn-out contacts? Hoping this will be a moot point soon with an imminent (?) upgrade :slight_smile:

I don’t have the same model remote as you have but I was curious so I popped the current model remote apart to see how it was constructed. It is using metal dome switches so the question is when it gets stuck does the button stop clicking when you press it. If it does then the metal dome is probably worn out. If it still clicks then it might have shifted a bit and if your really adventurous could attempt a repair by replacing the tape holding that dome in place.

I did take mine apart and give everything a clean, but back to square one when reassembled.

You didn’t say if the stuck button still clicked when it was stuck or if the repeating stopped if you pulled the battery from the remote. Those switches are covered with an adhesive film so you really don’t have an opportunity to clean the switch itself. Assuming it is the button that has gotten clapped-out, if it was me, I might take a knife and very carefully cut the film from around the problematic button, clean it and the board with isopropyl alcohol, distort it a bit more, and then stick it back down with some clear tape. If that didn’t work I would swap the dome with one from the button I used the least.

appreciate the suggestions. Done a bit more testing:

  • when the runaway scrolling starts, it continues even if I pull out the battery, and the list keeps scrolling to the end;
  • the behaviour occurs in both up and down directions
  • there is no change in feel of the buttons, they feel like they still click
  • all the above occurs while I’m doing a careful item by item scroll
  • hooked up the remote from my other Vero and all is fine.

While I like the idea of salvaging hardware, my credit card is on stand-by for ordering some new Vero V’s, so perhaps best to leave this one for now as it’s looking like the remote itself is flaky.

1 Like

I think that means the dongle has developed a fault then and there is nothing that can be done about that. The dongle for the remote is no longer available and the current model dongle is not backwards compatible.

They should be available soon.

well, based on this comment I just had a rummage through some old Vero boxes, and guess what I found? A spare dongle. No idea where that came from. Paired it with the iffy remote and all is now working perfectly :slight_smile: (note to self, this is why I don’t throw much away…)


You may want to check VID/PID, to make sure it matches properly, or some functionality like long press and re-mapping may not work as expected. We can help with that however.