Remote not responding when connected to my TV

update from My OSMC. Was reading some other threads, want me to do a fresh install?

I’ll get started on a new image.

Yes, try using the OSMC installer to do a fresh install. We suspect that the issue with the wifi driver in the previous image versions may have been causing corruption on some users devices.

The segmentation fault you got when running grab-logs suggests that there is some file system corruption on your device. I can also see some unusual crashes in the log that you provided.

Please perform an install of OSMC 2016.02-4 and report back


Still doing the crash/reboot loop. I can’t even get it to enable wireless, so i had to bring it back into the office to do wired to get logs:

let me know if you see anything interesting.

A question on SDcard installation. It gets to the screen that says “Successfully installed”. Is it supposed to automatically reboot, or do you need to manually power cycle the unit? I’ve let it sit on that screen for some period of time and it doesn’t do anything, so I’ve manually restarted. If i’m not supposed to do that then I could see that as causing a problem. Either way, a suggestion would be to add more detail to that screen (either “please reboot” or “system will reboot shortly, do not pull the power”).

Older versions won’t

2016.02-4 should. If you pull the power before then you won’t necessarily allow the filesystem to be written back fully which may cause some corruption. I’ll investigate.


Ok, that could be a problem. I’m very used to the system not doing it, so I didn’t wait long after I saw the message. Let me know if you want me to reinstall and wait for a reboot.

I’m a bit confused by your log. You say that Kodi was stuck in a sad face restart loop, but the log you posted does not show any kodi.old.log - which would be present if Kodi had run more than once…

What TV/screen did you have it connected to when you took the log file, and was it in a reboot loop then ? In the log you posted I can see Kodi starting but not crashing or even exiting. In fact I see nothing wrong at all in the log you posted.

You’ll see two different time stamps in the log, one that shows a Dec 31 16:00:03 date. This is when it was connected to my LG TV. It is in the living room with no hardwired access, so it needs WiFi to connect (which is why the date did not update). Because it had no internet connection, i tried to reboot it a few times to see if I could get one, but could not.

At that point I brought it into the office and hard wired it to the router, and plugged it into my computers second HDMI monitor. Time updated to Mar 12 12:58:39 because it was hard wired. The reboot loop stopped when plugged into the monitor vs. the TV (but the remote doesn’t work. Grabbed logs via SSH). It doesn’t look frozen at this point since I see the CPU usage going up and down.

Sorry if I made this confusing, I’m really not trying to (and believe me, I’m confused in spades right now). If I could do hardwired at the TV I would but that is logistically very challenging. I also can’t move the TV into the office because its a 65" TV. I’d be more than happy to do a step by step troubleshoot if you want me to do things in a specific order.

Appreciate all your attention to this.

Latest logs. got an odd grep message this time. I’m hoping this shows the crashes.

osmc@osmc:~$ grab-logs -A
grep: /var/log/apt/term.log: No such file or directory
grep: /var/log/apt/history.log: No such file or directory
Logs successfully uploaded.
Logs available at

I set up the device in my office, hard wired (fresh install). Put in the Wireless key, so wireless is ready to go.
Move the device to the living room, plug in external drive, boot up Vero.
Play movie from external drive. I run “ping -t” back in the office (ping the vero until i tell you to stop). Pings work just fine. Go turn on the TV again, vero is on a black screen. Pings now show “destination host unreachable”.
I power cycle the device, but as soon as it hits GUI it freezes. Can’t SSH in. I try twice.
Move the device back to the office and plug it in to my monitor. Boots up fine and I can SSH to get logs.
Don’t know if any of that is useful, but I’d rather give too much information than too little.

Which image did you use? As Sam has published a new one yesterday version 2016.02-04

The 02-04 image. Thanks for checking!

Don’t worry about those grep errors - it just means you don’t have any apt logs yet - eg you have not installed any updates.

That’s quite useful. It does seem like it is crashing as soon as you turn the TV on.

What happens if the TV is on before the Vero though ? Does that also crash ?

Can you try this for me. Edit /sbin/splash_early, the begining of which looks like this:

mount -t proc proc /proc >/dev/null 2>&1
export TERM=linux

if grep -qw quiet /proc/cmdline

After the line export TERM=linux add the following line:

echo 0x0 > /sys/class/amhdmitx/amhdmitx0/cec_config

This disables CEC support as early as possible during bootup - splash_early runs after the initramfs but before systemd starts the normal boot process.

See if it still crashes for you either if you turn on the TV after the Vero is on, or boot the Vero with the TV already on.


Vero has been off all night. Turned on, plugged into monitor and edited splash_early as requested. Transferred to living room. Powered on TV, selected correct input, plugged in HDMI and Hard Drive before powering on Vero.

Vero boots. Navigated to movie and started to play it.
Logs up to this point:

About 10 minutes in, movie is still playing. It stopped playing and dropped back to the file select screen, but no crashes. Started the movie back up and advanced it 10 minutes (trying to keep the “how far into the movie” as a time record). Turned the TV off.

I’m going to wait another 30 minutes or so before turning the TV back on. I’ll post updated logs at that point.

30 minutes later, and I can’t SSH into the device. TV is still off, but I’m going to check on it now.
Turn the TV on, and this is what I’m seeing:

Pull the power, and plug it back in. Now I’m getting this:

Pulled power again. Boots up this time, but is doing the frown face loop. I can still SSH in though, so I grab new logs:
Good thing I did. After typing all of this I can’t SSH into the Vero any more, and the screen is solid blue(ish)

Hope that helps!

I hate doing the “bump” thing, but I’m also getting a bit more edgy with my device being inoperable. Any news, or things I should be trying?

I’m willing to work on this as much as needed, but in complete honesty I’m getting a little disheartened at how long I’ve had this device without it being able to work correctly.

Thanks, I appreciate all your help.


I played with some ideas on the weekend to see if I could narrow this down, and haven’t come to any conclusions yet. I appreciate the frustration with the fact it’s still not working as expected.

Please forgive me if I am asking duplicate questions, as there is a near identical post where a user reports artefacts and jumping between the two I need to refresh myself each time.

Normally, I would consider this a hardware issue, but I keep seeing a crash shortly after some CEC related activity in your log. Have you tried another TV / display? Can you, do so, temporarily?

Do you have another 2A 5V power supply around? It is possible the power supply is defective.

Other than that, looks like we may need to RMA the unit and find out what’s going on.


Thanks Sam,

I can try it on a different monitor. I’ll hook it up to my old Vizio 32" TV that doesn’t have any CEC capabilities in it. Let me know if that is a poor test.

I’ll take a look for another power supply, but I don’t know that I have one handy. They are always different shapes and sizes so I’ll do my best to compare and make sure its spot on, but this is unlikely to be fruitful.

I didn’t bring the device to work today, so it will have to be tested tonight. I’ll do a similar log post as I’ve done previously.

I’ll be in touch!

Yes, I can understand this is a bit problematic. Don’t use a PSU above 5V. The barrel jack may not fit perfectly but if it’s a looser fit and you can hold it in temporarily to test that will likely be OK for a quick evaluation.

That would actually be a good test if it does not have CEC caps at all.


No luck with the power supply (haven’t actually looked, but I will).

TV without CEC still crashes. Here are logs:

First Boot

After Crash (during frown loop. I let it loop a few times)