Remote not responding when connected to my TV

Ok, so this is a confusing issues. After the recent update my vero is working much better in my test environment (thanks everyone!). However, when I plug it into my TV the remote doesn’t work. I can SSH into the box just fine, and if I plug a USB mouse into it I can work with that, but the remote that came with the device doesn’t work.

This seems to ONLY happen when I plug it into my LG TV at home. Any thoughts as to what could be the case?

That is a strange one. Do you get the same problem if you plug in a keyboard instead of a mouse ?

The USB receiver for the OSMC remote just emulates a standard USB keyboard as far as I know so it would be interesting to see if a USB keyboard has the same problem.

Tried the keyboard, and I got no response. I unplugged the keyboard, and all of a sudden all of the inputs I had tried (both keyboard and remote) started to execute at once (lots of ups and downs on the menu). I then got about 3 frown faces in a row, then got the static frozen screen I reported earlier.

Did an SD Card restore, but then it went through a terrible reboot loop. I’ve finally managed to get debug turned on, but the GUI freezes. (CPU = 136% ?). SSH’ed to get the logs though.

I’m still holding tight on this, but I’m concerned that something is wrong with the hardware.

I see a few things in your log, including:

Mar 04 15:28:59 osmc kernel: normal card in
Mar 04 15:29:01 osmc kernel: sd: SD Status: Invalid Allocation Unit size.
Mar 04 15:29:01 osmc kernel: sd: new high speed SD card at address b368, clock 39843750, 4-bit-bus-width
Mar 04 15:29:01 osmc kernel: mmcblk0: sd:b368 SDC   1.91 GiB 
Mar 04 15:29:01 osmc kernel:  mmcblk0: p1
Mar 04 15:29:01 osmc kernel: mmcblk0: r/w command failed, status = 0x80000b00
Mar 04 15:29:01 osmc kernel: end_request: I/O error, dev mmcblk0, sector 4019192
Mar 04 15:29:01 osmc kernel: Buffer I/O error on device mmcblk0, logical block 502399
Mar 04 15:29:01 osmc kernel: mmcblk0: r/w command failed, status = 0x80000b00
Mar 04 15:29:01 osmc kernel: mmc_blk_reset 940 reset error md->reset_done:1 and type:1
Mar 04 15:29:01 osmc kernel: end_request: I/O error, dev mmcblk0, sector 4019192
Mar 04 15:29:01 osmc kernel: Buffer I/O error on device mmcblk0, logical block 502399
Mar 04 15:29:01 osmc udisks-glue[378]: Device file /dev/mmcblk0 inserted
Mar 04 15:29:01 osmc udisks-glue[378]: Device file /dev/mmcblk0p1 inserted
Mar 04 15:29:01 osmc udisks-glue[378]: Trying to automount /dev/mmcblk0p1...
Mar 04 15:29:01 osmc sudo[1362]: osmc : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/usr/bin/tee /sys/dev/block/179:0/queue/read_ahead_kb
Mar 04 15:29:01 osmc sudo[1362]: pam_unix(sudo:session): session opened for user root by (uid=0)
Mar 04 15:29:01 osmc sudo[1362]: pam_unix(sudo:session): session closed for user root
Mar 04 15:29:01 osmc kernel: FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.

An SD card is inserted when this log was taken, and there are block IO errors that strongly suggest either the card is faulty, or is not making a good contact. (Possibly due to an iffy MicroSD adaptor) What is this card and was it inserted already when booting or did you insert it after booting ? Do you still have a problem with it removed ?

There are a few odd things in your log as well that I find hard to explain, and it looks a little bit like at least one of the Kodi crashes you had is related to My OSMC.

Can you try updating via the command line and see if you get a new version of mediacenter-addon-osmc ?

To do so:

sudo apt-get update
sudo apt-get dist-upgrade

And paste the results of that here, then reboot.

osmc@osmc:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... The following package was automatically installed and is no longer required:
Use 'apt-get autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

That is the results, so nothing upgraded. The SD card was in the Vero because I was doing a system restore. Next time I suppose I’ll wait until instructed to do one. I restored back to 2016-01-01 version, then did an update. Now I’m on the latest version (which is probably why the dist-upgrade showed no new things).

Everything seems fine right now, but I’ve still got it plugged into my monitor. I’m going to switch it to my TV, turn Wi-Fi on, and see if I can watch some movies. I’m trying hard not to use any specific add-ons, but my external drive is attached to my Pi. I’ll see if I can set that up for network sharing and do some more testing.

@DBMandrake System is still puking. Maybe its not the TV, and maybe it has to do with time in use. I don’t know, kind of at a loss. Its doing a reboot loop now, but I can SSH in before it crashes. Here is what I got:

I won’t touch it this time until I’m told to do something. Thanks for all your help!

Should have a kernel tomorrow for you to test and this may help with remote issue.

Cool, looking forward to it. Thanks!

Any news on this? Thanks!


We produced a new kernel but made some pretty invasive Device Tree changes, so we didn’t want to publish it for testing yet.

My new kernel simply disables CEC, as I’ve a suspicion that is what is causing the issue. I’ll let you know when we’re ready to have it tested.


1 Like

Please run these commands:

sudo apt-get update
sudo apt-get install vero2-image-3.10.94-30-osmc
sudo reboot


Installed update. I’m ignoring most of the little errors (frowny faces), mostly testing just to see if I get the GUI freeze again. Running in debug mode just to make sure I get the correct data for you.
It is crashing a lot more frequently, but its recovering from those crashes. One issue of note, wired Ethernet adapter cannot be enabled. I’ve switched to wireless for testing purposes.

Problem with an add-on, but that could be the add-on. I’ll put some movies on an SD Card or USB drive and see what occurs. I’ll keep the thread updated.

You can get the Ethernet up by editing /etc/modules-load.d/eth.conf to am_net_8218_osmc.

I’m not sure about add-ons , but try a fresh install without these add-ons and see if the issues such as freezing persist.


I’ll do a restore using 2-3, then perform the apt-get you suggested.

Error persists. This is after a fresh restore and the install of the 3.10.94 image linked above.

Could this be a timing/heat related issue? The device seems to work fine for a few hours (cold) but after it heats up, the error seems to make the device almost unusable. I only bring it up because it always seems at first like we’ve nailed the problem, then a few hours later it comes back up again.

Regarding CEC, this time it is connected to a monitor via HDMI to DVI. I can try a DVI only connection if you want, but the error seems to be the exact same to the one I get at home on my TV.

Hope some of this helps. :-/

So the remote works, but then stops working after a few hours?


That was the original problem, but now instead of it not working the whole system is just freezing and the GUI glitches out.

Downloaded latest update. I haven’t installed anything in the system, but I did plug in an external hard drive (self powered) to test. The remote freezing issue is gone, but my original problem with the screen wigging out is back. The Vero doesn’t stay on long without freezing, but if I’m quick I can get logs. Here is what putty told me:

osmc@vero:~$ grab-logs -A
Segmentation fault
Logs successfully uploaded.
Logs available at

Here is what the screen looked like as it crashed:

Let me know if there are further tests I can do. I’m still thinking that this is possibly a heat/time related problem since the device behaviors very poorly when this occurs, but leaving it powered off for a day allows it to be used normal for a period of time.

Did you just run an update from My OSMC or an apt-get dist-upgrade, or did you do a completely fresh install from the new 2016.02-04 image ?