Vero 2 Problem

As requested, below is a link to the video. This is typical of what it has been doing since the initial startup. You should probably hear a buzzing sound. At that point, no further CEC inputs work nor does SSH on most occasions.

Hi Chris

It does not look like your TV is to blame.

That does not look good. I will produce a kernel for you shortly to test your device and we can rule out a couple of things. Worst case scenario we will just have to replace it for you.

  • Do you have any other power supply which is 2Amps, 5V with the same jack? The issue may be the power supply. Your parcel has certainly travelled a few miles from the UK. How did it arrive? Any visible signs of drops / knocks?
  • Are you powering it directly from the wall?
  • Is the device getting warm when it starts playing up? Feel the bottom of it

I appreciate your patience with the installer.


Thanks Sam,

After leaving the Vero powered off overnight, on startup, it actually worked correctly for around five minutes. At the five minute mark, artifacts were introduced to the display. Around 30 seconds after that, the system crashed and continued in a power up/crash cycle.

I tried two other 2 amp, 5v power supplies but it wouldn’t power up (front blue LED blinks). I suspect they don’t provide sufficient quality power.

The packaging arrived without any major signs of deformation. There is slight damage to the outer box but nothing that you would’t normally expect from international transit. The inner box showed no evidence of damage.

I am currently powering it directly from the wall and have used multiple power points to confirm that they are not at fault. The point I am using also runs a Rpi 2 without issue.

The device feels quite warm on the base after five minutes use. I don’t know if this is normal or not. There are no rattles when the unit is lightly shaken to indicate that something is broken internally

If this was any other device, with the symptoms that it presents, my immediate suspicion would be that it is overheating due to the progressively degrading nature of the failures the longer the device is powered on however I do not know enough about the Vero 2 to make a definitive assessment. Is there a way to test the temp within the system settings as you can with the Rpi?

Thank you for your help with this.

I’m facing the exact same problem. Mine does not stay up long enough to ssh into it. Just osmc logo and either the unhappy face, a menu that last only about 10 or 15 seconds before it either goes back to the unhappy face or it slightly distorts picture with a buzzing noise and jumble the image. Sometimes settling on a dark blue screen, light blue screen, or a gray screen, etc, etc.

I’ve tried re-installing OSMC to no avail,
I’ve tried testing different hdmi cords,
I’ve tried different power supplies that are 2A/5V,
I’ve tried in wall and in a powerstrip,
I’ve tested on 3 tv’s, (Magnavox, Vizio, Samsung smart tv) nothing seems to work.

The unit is rather cool. Not really warm or anything. Some heat comes out of the bottom but it’s not major.

And lightly shaking it, I do not hear any sounds of anything loose in the unit.

However whenever I replug the device into my magnavox tv, before the vero 2 boots up 100%, unlike my Samsung or vizio in the other rooms, the magnavox states that the vero2 is using a resolution and refresh rate that the tv does not recognize,

Image provided to give more details on what it says. Dunno if it helps or not.

I believe we have identified and have a fix for this issue:

I’ll build a new image soon when we get some other fixes in. It should be ready for Monday evening.


Hi guys,

Just to give you an update, I have updated my Vero 2 to the latest version (WEF 06 Mar 16) and still get the same problems. This is the link to my latest log:

The same behavior as previously reported is continuing. Initially the unit is usable for around five minutes and then it crashes. From that point on it steadily degrades to continuous crashes of around 10 seconds after each reboot. I don’t seem to be getting the artifacts prior to crashing since the latest update nor does the screen freeze anymore as per the video I posted last week. So there has been some progress with the updates. Do you have any additional suggestions as my Vero 2 is still unusable?

I see from your log that you seem to have the UPNP server enabled. Does it crash if you disable that ?

Other users have reported crash related bugs in Jarvis when UPNP is enabled on the Raspberry Pi so there may be a general UPNP bug in the current version of Kodi. You may need to delete your Kodi preferences to revert to defaults to stop it crashing before you can reconfigure your settings. From SSH:

sudo systemctl stop mediacenter
rm -f /home/osmc/.kodi/userdata/guisettings.xml

Now Kodi should boot with default settings - configure your normal Kodi settings but do not enable UPNP. Let us know if that has any effect.

Thanks DBMandrake,

Ok, again there was initially some improvement as I got at least 10 minutes of video playback this time before it crashed. I forgot to re-enable logging after reverting to defaults so it didn’t capture that crash. I did not adjust any of the default settings except to commence scrapping my movie library.

The display artifacts prior to crashing and display distortion and buzzing noise are also back.


I have updated to version 2016-02-04 and my issue is still unresolved. The only consistent thing I can say is the unit works for between five and ten minutes before failing and then becoming unusable for around two hours (fails to load without immediately crashing). After two hours turned off, the cycle may then repeat. For what its worth, attached are the latest logs:

I’m convinced that the issue must be hardware related in my particular unit only as most other similar problems on the forums seem to have been identified or resolved by the OSMC team fairly promptly through the updates. Do you have any further suggestions or recommendations as this issue is starting to become a bit frustrating?

If you have only updated via My OSMC then we would recommend you do a fresh install with the latest image, as a couple of the bugs that we fixed were causing corruption, so after you have updated although the bugs are fixed prior corruption would still be present and cause you issues.

What do you mean by crashing ? Please be more specific than that. Do you mean the whole system freezes ? Or Kodi crashes back to the sad face screen ? Can you still log in with SSH when it has “crashed” ?

I don’t see any sign of a Kodi crash in those logs, so assume you had rebooted before capturing the log ? Unfortunately the log doesn’t help if this is the case.

If the crash you are seeing is something where you can still connect with SSH, then when it happens please log in with SSH and run grab-logs -A to capture logs.

Until you’ve done a fresh install of the new image instead of an upgrade I would not assume it’s a hardware problem.

I did a full re installation to this version and repeated tonight. Still have the same issues.

As a side note, one of the things that convinces me that it is hardware is that re installations fail if I have been using the unit too long (if I have been working on it for more that 10 minutes). If I leave it turned off for a few hours, then it installs without any issues using the exact same image.

When I say crashing it consistently follows this pattern:

  1. 5- 10 minutes normal use

  2. random blocks appear and disappear on the screen. Each only lasts a fraction of a second. Similar to digital TV interference.

  3. crash to sad face and return to main menu after 5 seconds.

  4. go for between 5 - 10 seconds before sad face reappears (repeat this for around five occurrences)

  5. after a few more minutes get a loud noise from the speakers and screen goes random colours or image is greatly distorted. Screen unresponsive, so is SSH. I’ll try and force it tonight to capture a video.

  6. Hard Reboot, sad face cycle repeats after a few seconds.

  7. Pull plug and walk away. Come back two hours later. Start from step 1.

As I said in previous posts, this pattern is repeatable and consistent irrespective of which version I have installed.

After it starts the sad face loop, I am unable to log in via SSH as it doesn’t give me enough time between responsive periods. I used grab-logs -A to capture my previous logs after rebooting the device due to its lack of responsiveness. This log was captured after a hard reboot and crash to sad face

I would disable Kodi with sudo systemctl stop mediacenter and leave the Vero on for an hour or so. Do you still get glitches? This will provide a clue as to whether the issue is Kodi related or not


DBMandrake - Attached below is a short video of what I have been referring to as a crash.!3494&authkey=!AAb3rEZgF8Vg_Xs&ithint=video%2CMOV
SSH or screen inputs don’t work at this point. I am able to force it using confluence however it also occurs on the OSMC skin (though less predictably)

Sam - I disabled Kodi as per your instructions. No glitches appeared after one hour, just a black screen with six text lines on the top left side.

Thanks for reporting back. Can you try this?

sudo apt-get update
sudo apt-get install vero2-image-3.10.94-33-osmc

Might take 30 mins or so for the CDN to get those new kernel files. After installation, run ‘shutdown -h now’ and unplug Vero from the mains for 60 seconds.

Can you also confirm that the Vero is still responding over SSH after all this time?



Hi Sam,

I installed the new kernel. On reboot after the 60 second powered down, it went into the sad face loop again at which point I captured the log, before crashing (as per previous video)
At what point are you asking if it is responding to SSH? On the sad face loop it is responsive some of the time. Once it crashes as per the video, it will not respond to any inputs.

Hi Chris,

Apologies for the delay in my reply. Thanks for trying out our suggestions so far, I do appreciate this is quite annoying.

If I understand correctly, if Kodi is stopped (sudo systemctl stop mediacenter), then the device remains responsive for a significant period of time, including SSH connectivity, and that the device has issues when running Kodi.

If you can plug the device in to another display to test, that is another thing that we can rule out. It may also be the power supply. If you have another 2A 5V PSU at hand you can give that a go and see if it makes a difference.

I have another customer who is experiencing this issue and he has posted the device back, so I should get it soon. I’ll test the device and peripherals (PSU etc) and see if I can find out what’s going wrong. This may give us a clue as to what is wrong with your device as well.



Hi Sam,

I understand that you guys are getting swamped at the moment. I truly hope that we can identify the issue without having to replace the unit and I can wait a little longer for you to analyse the other returned unit (considering how long it would take for mine to get back to the UK).

The device is responsive when Kodi is stopped using sudo systemctl stop mediacenter including SSH connectivity. Note that this is only the case when I am going from a cold start. Normally I cannot run the ssh commands after the unit has started the sad face loop. It is only when Kodi is running that I have seen the reported screen distortion. When kodi is stopped, is the unit under any significant load?

I have been watching this other thread and many of the reported issues are very similar though mine was doing it out of the box. Remote not responding when connected to my TV - #4 by Guy

I’ll purchase a new PSU on the weekend and give it a go.

Hi Chris

Yes – I can understand the frustration in shipping back a unit to us and waiting for us to send it back to you.

When Kodi is stopped, the device is not under significant load, which could mean that the device is only encountering a problem under some power draw.


Hi Sam,

As an update, I purchased a new 5V 2A power supply and there has been no change in the devices performance. The sad face loop followed by screen distortion continued exactly as it did prior to the change in power supply.

Any luck with the other customers that you were testing?



@DBMandrake can now replicate this issue so we are working on a likely cause

What skin are you using?