Remote not working and Hauppauge DualHD not detected

I’ve had some problems with my OSMC remote not working after a reboot. I’ve re-paired it a few times after updates etc but the vero 4k+ crashed while I was away and it now also appears my Hauppauge DualHD tuner isn’t detected either. Remote dongle is plugged directly into Vero and tuner into the a powered hub along with a USB drive which itself looks seems fine. Any ideas?

logs here

Did the tuner work before?

Yes. We don’t watch live TV that much any more so I can’t be sure when it stopped working. I can check when the last recording was made of that would help?

That would help, maybe we can then tie it to a specific release. We have done some work to support some Hauppage devices, but I’d be surprised if this caused a regression.

Detected where? In TVHeadend?
From the logs looks ok

Aug 22 17:54:29 osmc kernel: si2168 3-0067: Silicon Labs Si2168-B40 successfully identified
Aug 22 17:54:29 osmc kernel: si2168 3-0067: firmware version: B 4.0.2
Aug 22 17:54:29 osmc kernel: si2157 5-0063: Silicon Labs Si2147/2148/2157/2158 successfully attached
Aug 22 17:54:29 osmc kernel: DVB: registering new adapter (em28174 #1)
Aug 22 17:54:29 osmc kernel: usb 1-1.2: DVB: registering adapter 1 frontend 0 (Silicon Labs Si2168)...
Aug 22 17:54:29 osmc kernel: em28174 #1: DVB extension successfully initialized
Aug 22 17:54:29 osmc kernel: em28174 #0: Registering input extension

In that log I don’t see it detecting a dongle for an OSMC remote. If one is plugged in I would try plugging it into a different USB port and if that doesn’t bring the remote up I would try testing it on a PC.

Last recording that worked 12/08/23 07:38
First failed recording 16/08/23 19:58


Yes, TVHeadend has no adapter in the DVB Inputs tab of the configurator

OK, progress. TV adapter is back after reboot, not sure what I did maybe power cycling the hub did it., and it’s still OK after another reboot. So think that’s ok.

Remote dongle is found on the PC as an “Unknown USB Device (Invalid Device Descriptor)” and will pair (as it does on the Vero) but I’m not seeing any input from the remote. Wasn’t really sure how to test for input, tried notepad and vlc and didn’t see any signs of life. Think it’s kaputten.

Do you have a dongle you can send? Happy to pay/contribute to cover costs.

Edit: did try dongle on another usb slot and it worked but was gone on reboot and wouldn’t pair again.

You can contact with your order number and we can check this.