Remote not working in Kodi - CEC issue

Ever since December update and that issue with OSMC not booting due to sdcard driver change, my OSMC/PI has gone crazy. Right after that issue my sdcard died. Then when reinstalled and running from USB, addons did not restore completely so almost had to configure everything again. And what gives me most trouble is the remote not working. Actually it only works from time to time and I cannot get a grasp on when it actually works. I have tried rebooting, enabling/disabling CEC on my TV( Viera link on Panasonic ST series), changing the cable, removing the second HDMI device on my TV (A/V receiver) but still acts crazy and right now does not work at all.

My setup is:
Raspi 2 connected to HDMI 1 on my Panasonic TV via short HDMI cable. It has been like this for 1+ year
Sony A/V receiver connected to HDMI 3 on my TV. My IPTV STB is connected to this A/V Receiver.

At first, when I connected this IPTV to the TV directly, the remote in Kodi did not work. So I realized that if I connect IPTV to receiver and than to TV, remote works. Unfortunately, now it doesn’t work even if I leave only PI connected to my TV.

In case someone is willing to help debug and make this work, I would appreciate it.

All logs here:



Someone? Please? At least to tell me how do I start debugging? Thanks

I have just applied the latest update and the remote started working. Not sure if its related to the update or it started working on its own but I will update if there will be any changes.

I also have CEC issues with my setup so I wonder what exactly have you updated?

Unrelated to your issue, the update was only for the My OSMC settings addon.

BTW, not cool to keep bumping your thread - if anyone knew the answer to your questions they would reply. Three bumps is a row is not good forum etiquette.

It is hard for me to believe that no one knows how and where to start debugging.

This is a huge issue for me so that’s why I don’t want the thread to disappear where no one will ever even try to help.

Is there is a way to move my issue to the top of the list (paid support?)? If yes, please let me know. If not, you can always ban me if I’m violating forum rules - but honestly, I don’t see any other way to overcome this situation.


Not to be rude or anything, but everyone thinks their particular problem / pet peeve with a piece of software is top priority, but the reality is that there are hundreds of thousands of users using OSMC and a small handful of people who actually work on the software and try to give support in their own spare time.

The number of posts on the forum make it physically impossible for all questions/problems to be answered let alone solved. There are only so many hours in the day.

Repeatedly bumping a thread just wastes the time of everyone who comes to read the thread only to find that there is no further useful information in it, so please stop doing that. As I said before, if nobody has answered after 3 bumps that means nobody who has enough time to answer your post among the hundreds of other new posts has the answer you’re looking for.

You need to unplug your TV from the mains for a few minutes.

Thanks Sam. That did not resolve the issue but did help me narrow down where the problem is. Seems to be working now.


Kakovako, pecni me na priv poruku.

So for the benefit of others reading this, what was the cause ?

Havent read all the answers. But unplug everything that is connected with HDMI and start the TV with kodi as the only connected device.
I treied “everything”, even bought 3 different HDMI cables just to find out that my cable-tv box was messing up the CEC. Now i have to unplug the cable-box from the tv when i turn the tv on if i want to use CEC.

Had exactly the same issue. Resolved by having only av receiver connected to tv ( pi and stb connected to receiver).

I have the same problem.

I have three raspberry pi 3s running the latest version of OSMC. All of them were set up within the last three weeks. I use a Logitech Harmony 650 as the universal remote. I have all of the remotes configured the same way. Kodi is configured with Apple’s silver remote. The 650s are setup with the Raspberry Pi as an Apple tv device.

All three Raspberry Pis have a TSOP38238 IR Receiver set up by following Adafruit’s tutorial.

The Raspberry Pis and the remotes were purchased recently, and the remotes have new batteries.

Each room has a different TV. The one where it stops working at random has a ten-year-old, flat-panel Samsung TV. One room has a receiver and the remote always works. The other two rooms do not have a receiver, but it only fails in one of the rooms.

In two rooms, I never have an issue. In the third room, the remote randomly stops working.

In that third room, I tried disabling CEC in /boot/config.txt and adding the pull-up resistor via Kodi’s GPIO interface. Neither has an impact. The remote will randomly stop working.

The first time it randomly stopped working, I reprogrammed the remote, and everything started working again. The second time I reflashed the microSD card and setup OSMC. The third time, I just let it sit for a couple of hours and everything started working again.

I think there are only two possible solutions left:

  • The USB power plug is different, and I will swap them to see if the issue follows the plug
  • Is there a service that I can monitor via a cron job and restart when the remote is not working? If yes, what is it?

I had struggled with the same CEC problem. After working fine the past few years, my Samsung TV remote suddenly stopped responding to OSMC/Kodi .
(regular TV worked fine using the remote, so batteries & electronics were not defective)

I had to use a keyboard to control Kodi. Tried everything to fix it, settings, updates, restarting… now I changed to a more powerful USB power supply for my Raspberry Pi.

Now it works just like before! Perhaps power supplies degrade after a while.