Remote sporadically working

I’ve recently been having issues with my remote. Pushing buttons on it may or may not work, though the blue LED always works when pushing a button. Battery has been changed and is at full voltage and I’ve tried the re-pairing procedure and it doesn’t seem to help.

After reading other people’s similar problems, I guess it’s probably the dongle. What can I do to confirm and/or fix?

You can plug it into a PC and see how it acts there. On a PC the buttons will be for the last couple models of the OSMC remote…

Home = home or escape
Info = i
Direction keys are the arrow keys on a keyboard
OK = return/enter
Back = backspace
Menu = c
Play = multimedia key play
Stop = multimedia key stop
Vol- = “-”
Vol+ = “=”

If you have something very near your device that has a strong rf signal this can cause that kind of an issue as well.

Aside from @darwindesign’s suggestions, you could also try the other USB port.

It would also be good to know if you have any attached peripherals like a USB hard drive, and if your device is in close proximity to a router or wireless keyboard/mouse


As per @darwindesign 's suggestion, I tried the dongle and review on my computer and it seemed to work more or less consistently.

I did have a Bluetooth wireless keyboard dongle in there as well. I removed it, but didn’t help. I also switched the usb ports which didn’t work.

The Vero 4k is a couple of feet away from the router, but honestly, it’s been like that for years, so I don’t see why all of a sudden it would stop working.

I do have an app on my phone called Kore that is capable of controlling it, but I believe that connects via the network. Besides, it is not my preferred way to control it.

Can log files show anything? How far apart should my Vero and the router be at a minimum? I don’t have a lot of room to play with, and, as I’ve said, it has worked fine all this time and nothing has changed.

I don’t know how close is to close, just that it is something that has come up a few times with users. You could try pairing your remote a few times or change which 2.4ghz channel your router is using and see if that can rectify the problem. Alternatively if you have a USB extension cable laying around you could try plugging your dongle into that so you can see if you can find a spot for it that picks up better.

In the end, moving the device seems to have fixed the issue.

Thank you @darwindesign for the idea of using a usb extension to get the dongle further away. I would never have thought of that.

1 Like