Remote stopped working

I believe you already contacted me about this yesterday, on Sunday.
I’ve followed up on this


Thank you very much

For about a month, came with a Vero 4K.

So the remote and the dongle have been lying around for a couple of days, one without the battery and the other without being connected to anything. I tried it with my Mac today and it actually worked, but only once. Subsequent attempts to use them with either Vero or Mac failed — it still doesn’t work, showing symptoms described before. A Windows VM doesn’t complain about the receiver though.

Tried pairing in a different room with no luck. Didn’t have a chance to get a new battery yet, still at 2.92 … 2.94 V.

They can sometimes fall out of sync if they are paired in an environment with a lot of 2.4Ghz noise. I remember a user once had a problem a couple of years ago. The solution was to pair the remote with a laptop in a quiet room in the house, then reintroduce the remote and dongle to the main living room. This also resolved a rapid battery drain issue that the user also had.

Give it another go; otherwise we can happily swap it over for you

When you sell a lot of these; it’s inevitable that one or two will go wrong.


Just as a FYI, today 8 weeks after the first post the remote got unpaired again.

Had to re-pair with the steps under “2.” and that fixed it. Will keep you posted. No need to reply.

Should be fine


Having the same issue with mine. Was driving me crazy till I found this thread. It looks like my remote is dead. Tried new batteries and the dongle works fine on my PC. Tried to re-pair as per step 2 in the OP. Nothing. Sods law I guess, I purchased this on the 29th Feb 2020 so its a couple of days out of warrenty.

What are my options. I dont really want to buy another one of the same remote as I always felt it was the weak link quality wise. Any other good 3rd party ones out there?

What is the actual issue you are experiencing? If the remote works on a PC then it is functional.

The post you’re replying to is over three years old; so it would be good to have some more information.

Hi Sam,

The remote doesnt work on the Vero 4k + or on my PC.

When I plug in the dongle to the PC, it finds that and recognises it so I assume thats not the issue.

Ive ordered this for now as figured it would take a while to resolve.

  • Remove the USB from Vero 4K / Pi
  • Hold Home and OK button for 5 seconds or so, then the blue LED will keep flashing.
  • Plug in the USB receiver and the LED should flash 3 times after 5 seconds, indicating successful pairing.
  • Power off Vero 4K / Pi for 2 minutes. Turn it back on. The remote should now work.

Tried all that, nothing.

Some logs would be useful.