Remote stopped working

It’s suddenly not working anymore.

The blue led is flashing around 0,5s when i press a button so it seems to not be paired with the dongle.

I restarted a few times but that didn’t fix it.

Tried to re-pair the remote:

  1. Removed battery and dongle. Inserted dongle. Inserted battery. Still nothing
  2. Removed dongle. Hold OK+Home until led is ON. Then re-inserted dongle. Still nothing.

Anything else or should i contact for a replacement?


When you do this, what do you see on the remote?
Does the dongle show up under dmesg | paste-log?

We will replace under warranty, but first we want to know if the remote or the dongle has malfunctioned



When the LED is on and i plug the dongle back in it takes around 20s for the LED to simply turn off. No blinking.

I have no idea but please take a look:

At the end of the logfile it says that it found the dongle a few times (that was me trying to pair it again). So the USB part of the dongle is working but the pairing part is broken of either the remote or the dongle.


Dongle is fine, looks like a possible issue with the remote to me.
Try pair it on a Windows PC or Mac in a more quiet room if there’s a lot of connected devices nearby.

Failing that, send an email to or PM me and we will swap it over with a replacement remote + dongle


Tried to pair with a Macbook and it worked at first but when going back to the Vero it didn’t work again.

I then checked the battery and it only had 2.8V. So i changed it and now it works flawlessly.

This device is 4 weeks old - thats why i ruled out the battery being low at first. I think you should check the batteries you are shipping.

Batteries should be OK. Did your battery look damaged in any way?

The remote battery can drain very quickly if the remote becomes unpaired and they spend a lot of time frequency hopping.

No visible damage to the battery.

I have no idea why it should have become unpaired by itself. Updated to the Sept. release and everything was working perfectly. Then suddenly stopped working.

Will keep an eye on it and post again here when the issue would return.

Best regards & thanks for your support!

The remote will usually unpair if it isn’t able to communicate with the dongle for some time.

It shouldn’t be an issue now, but let me know if you run in to further troubles and we can swap the device over.


I mean, i switch the Vero 4k completely off (central power switch of the home theatre) when i’m not using it.

Could this drain the battery or cause an unpairing?

I have a similar problem with the remote not working after September’s update. It started with only some keypresses not being registered by Vero, now all the keypresses are ignored. The remote LED is lit for longer on key press, compared to when it was working.

Tried re-pairing with Home+OK, still doesn’t work. LED blinks steady and blinks three times afterwards. The battery is 2.93 – 2.95 volts. I keep my Vero always on, the remote is in proximity at all times.

Is the wireless remote functionality dependent on OSMC/Linux at all?

Tried it now with my Mac, doesn’t seem to work either, same symptoms as with Vero.

[157030.192112] usb 1-1: new low-speed USB device number 5 using xhci-hcd
[157030.340064] usb 1-1: New USB device found, idVendor=2252, idProduct=1037
[157030.340077] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[157030.340083] usb 1-1: Product: USB Keyboard Mouse
[157030.340088] usb 1-1: Manufacturer: HBGIC Technology Co., Ltd.
[157030.350917] input: HBGIC Technology Co., Ltd. USB Keyboard Mouse as /devices/c9000000.dwc3/
[157030.351121] hid-generic 0003:2252:1037.0007: input,hidraw0: USB HID v1.10 Keyboard [HBGIC Technology Co., Ltd. USB Keyboard Mouse] on
[157030.360071] input: HBGIC Technology Co., Ltd. USB Keyboard Mouse as /devices/c9000000.dwc3/
[157030.360333] hid-generic 0003:2252:1037.0008: input,hidraw1: USB HID v1.10 Mouse [HBGIC Technology Co., Ltd. USB Keyboard Mouse] on
[157030.439139] input: eventlircd as /devices/virtual/input/input21

That should only occur if you leave it off for a long period of time (weeks / months) and there are accidental button presses in this time.

Hi @Forst

Not at all.

How long have you had the remote?

This means the remote isn’t paired with the dongle.
The minimum working voltage is technically 2.2V, but that is after pairing.

Personally, I’d try re-pair in a different room and change the battery.

Failing that, send me an email and we’ll get this resolved for you.



Same issue for me.
Try to re-pair the remote with the dongle in Windows (apparently succesfully) but no way to make it working on Vero 4K.
Vero 4K is brand new. I used it only for a couple of days.

Are you saying that the remote works in Windows?

Plug it in to the Vero 4K and reboot.

No, it does not work since Windows is saying “USB Device not Recognized”

Can you show me Device Manager?
Otherwise just contact the sales email and we can do the RMA

From Windows Device Manager

Okay – the dongle looks like it might be problematic here. Let’s get it swapped over.

May you inform on how to proceed now?