Remote stopped working

Purchased Vero 4k just under 6 months ago.
Has been a joy until today. Device is usually on all the time, but booted down last night and turned on today - the default remote is not working.

  • Changed battery - can see blue light fine, but still does not respond.
  • Removed the USB from Vero 4K
  • Home + OK button + 3 seconds = blue LED remains solid on
  • Plug in the USB receiver, place remote right next to vero
  • Remote does not flash, and solid light ends up turning off. Remote still not responding.

I also tried putting the USB into the other port and repeated the above - same result.

I also tried putting the USB into my Windows 10 PC - can’t see it recognising the USB, nothing appears.

Can someone advise if there are any additional troubleshooting steps (keeping in mind I don’t have a remote) and what the next steps are?

Can you put the usb in OSMC and go to My OSMC and upload logs? It will show me if it is detected.

Thanks @sam_nazarko

Trying again:

  • Switch to OSMC default skin
  • Take USB out
  • Enable debug logging
  • Enable event logging and enable notification event logging
  • reboot device
  • plug in USB and attempt pair from remote (home + OK steps)
  • upload all logs -

Do those logs indicate a hardware issue with dongle or sonething else? Happy to try additional troubleshooting steps

Sorry — I didn’t get a chance to check this yet. I’ll check later today


Thanks, I’ve had a chance to check this now.

Your log doesn’t show the dongle attached. If you email with a link to this thread and your order number we can get this sorted for you.


I wasn’t sure if I should start a new thread but I’m having a very similar problem. Everything was working for about a week and then the remote started barely working. By which I mean when I press a button on the remote usually nothing happens, but if I keep trying it will eventually work. So I have to press the button a bunch of times for every move I want to make.

I tried re-pairing and everything else I’ve seen in other threads. When I plugged it into my Windows PC it did basically the same thing, except that every time pressing a button on the remote didn’t work, Windows made an error sound as if it got a command but couldn’t execute it. But after trying a bunch of times it eventually works, just like on the Vero 4k.

For now I’m just using a USB keyboard to control Kodi because it takes forever to navigate or pause or stop or anything with the remote, but any help would be appreciated. :slight_smile:

Enable debug logging, reboot than press a couple of buttons. Record which button press didn’t show a reaction. Upload the log, share URL and your key pressed pattern.
To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

I didn’t know which logs to select for the file so I selected all but a quick look at it suggests I definitely didn’t need it all, but I think I see the remote things happening towards the bottom.

After the reboot I used the remote and pressed “up”, “right”, “down”, and “ok”, in that order, and it did not work any of those times. I wasn’t sure if it would be best to keep pressing until one worked so it could log a working button press but that may have taken a long time so after that I just used the keyboard to get the logs.

EDIT: I need to redo it showed my password. :o

EDIT 2: Okay here is the new log which I checked every line to make sure no password is there, but I hope I selected the right logs with the right info:

For this one, after the reboot I pressed “down” three times, and it worked on the third button press but not the first two. I then pressed “up” three times and “ok” once, none of which did anything at all. Then I used the keyboard to go to My OSMC and grab the logs.

Did you try a new battery?

Oh tbh I didn’t try that because the issue started only one week after I started using it so I didn’t think it could possibly be that. And the blue light on the remote always works every time I press the button, but I suppose I could order one and see if that works. I’ll feel awfully dumb if it’s that…

Okay I finally got new batteries and putting a new battery in it did not help. It’s still doing the same thing. :frowning: Is there anything else I can try? I really liked having the remote for the one week it worked…

Looks OK here:

May 16 02:54:16 simon kernel: usb 1-1: Manufacturer: OSMC Remote Controller 
May 16 02:54:16 simon kernel: input: OSMC Remote Controller  USB Keyboard Mouse as /devices/c9000000.dwc3/
May 16 02:54:16 simon kernel: hid-generic 0003:2017:1688.0001: input,hidraw0: USB HID v1.10 Keyboard [OSMC Remote Controller  USB Keyboard Mouse] on
May 16 02:54:16 simon kernel: input: OSMC Remote Controller  USB Keyboard Mouse as /devices/c9000000.dwc3/
May 16 02:54:16 simon kernel: hid-generic 0003:2017:1688.0002: input,hidraw1: USB HID v1.10 Mouse [OSMC Remote Controller  USB Keyboard Mouse] on

Is the blue light a short or long flash?

Can you confirm how you tried re-pairing? The remote is showing as operational on your log.

Of course it can be replaced if it’s faulty, but it doesn’t appear to be. We’ve had a few returns lately that have been caused by a low battery / simply needing re-pairing.

I followed the same steps to re-pair as was listed in the first post above. I noticed in another thread you said after holding home and ok it should flash after five seconds but like in the OP mine goes solid blue until I plug the USB in, then it blinks three times, I power down for two minutes and when it’s back on it still only works rarely when I press any button.

As for the light when pressing a button, it’s a shorter light when the button press works, longer every time it doesn’t work. Also when I had logging enabled and could see numbers in the top left, whenever the button works the MEM doesn’t really do anything but every time it doesn’t work the MEM number goes up and then comes back down I think.

As I said earlier when it was plugged into my PC it gives me an error sound when a button press doesn’t work so it does seem to be both sending and receiving a signal, it just doesn’t execute a recognizable command most of the time. I figured that meant the hardware was fine but there was some kind of glitch but I really don’t know.

So since the logs apparently show there is nothing amiss and neither new batteries nor re-pairing have any affect should I buy a new remote and dongle hoping that fixes the issue or is there anything else I can do to see what’s causing the issue?

Email with your order number and initiate an RMA. It will be replaced free of charge under warranty

Hey Sam

Have been in touch with support and about to drop this in the post
As I am in Australia, want to make sure I get this right. Was there anything in the logs to indicate an issue with the USB port over the dongle itself? I guess an easy test to rule this out would be to plug a mouse into the port (will try when I get home this evening).


Nothing to suggest a port issue instead of dongle issue; but logging isn’t that extensive.

Try the dongle in a PC and see if it works / lets you scroll a web page using arrow keys.