Remote suddenly not working

Everything was going perfectly fine with my Vero 4K+ setup until last night. I was able to use my LG magic remote as well as the remote that came with Vero device. For se strange reason both stopped working last night. I don’t think I made any changes to any settings.

The logs are here:

Would appreciate if someone can take a look at the logs and advise.


The USB dongle is being detected OK
Have you tried repairing the remote?

I have tried unplugging the usb dongle and pressing home and ok buttons together. But I don’t see any light that’s supposed to come up after a while.

One thing that I haven’t tried is replacing the battery on the OSMC remote. But a bad battery doesn’t explain why LG Magic tv remote doesn’t work either anymore…

Well might be just a coincident that CEC failed at a similar time.
Would suggest to power off TV and OSMC at the mains for a couple of minutes and try if it works after reboot.

For OSMC remote suggest to replace batteries if you don’t see a light at all.

Changed the battery on vero remote and everything started working.

With the bad battery in Vero remote even the LG tv remote wasn’t working but somehow it started working as soon as I swapped out the battery on Vero remote…

I don’t think it’s possible for the OSMC remote to impact your TV’s remote functionality, particularly when it has no power.

You can prove this by unplugging the Vero’s USB receiver. It will not impact CEC.

Conversely, the OSMC remote will also work when CEC (your TV remote) does not.