I have the most annoying problem with the remote control for my Vero 4k+:

When it works, it’s great. The range is good, the reaction to button presses is fine. And usually, it does work.

But on occasion, it does not. There are two “modes of failure”:

a) The “back” button doesn’t work, all the other buttons do
b) ONLY the “back” button works, all the other buttons do NOT work.

(I can still control the Vero by IR remote, therefore I know the unit itself hasn’t crashed.)

The problem is most often triggered by a reboot e.g. after a firmware update. Then it takes a sequence of shutting down and rebooting the Vero, and sooner or later it starts working again. It’s worth noting that rebooting and shutting down are not the same for this, often rebooting doesn’t help, while shutting down does. Right now I seem to be in a state where none of the two helps, I can get into either one of the failure modes, but I can’t get all the buttons working again at the same time.

It’s as if the remote is being detected as a different model or something. Or maybe it could be RF interference during some critical detection phase on power up?

Do you have any suggestions? I’ve come to fear every blue screen or planned reboot for afterward surely this jumping through hoops will start again… :frowning:



… just solved the problem for one more time:

It must have started when this morning my power went out for a few minutes. That was the Vero reboot that started the trouble again.

To recover, I pulled the power from the Vero and left it sitting for a few minutes. Then powered back up: “mode a)”, no back button.

One more reboot (not a power down): Bingo, both working again.

Before, I tried a sequence of power down and reboots but could only get from one failure state to the other. The letting it sit without power for a while seems to have done it for now.

No clue, seem to be a very unique issue. Does unplugging the dongle and plugging it back in do the same thing, or just when the Vero power cycles? I don’t see it being a detection issue though. We do identify the dongle on boot and use that to remap some keys and load special keymaps, but that not happening wouldn’t cause what you describe. Have you tried re-pairing it and/or putting in a new battery? If you provided some logs there may be some clue in them.

I would indeed check if a re-plug works as @darwindesign suggests.

Can’t see how this would happen.


… you didn’t change anything on your side, did you? Because the latest update installed and rebooted without the slightest hitch. It hadn’t done that in months, every restart used to be a fight to get the remote back. This time, it was flawless. :slight_smile:

I’m hesitant to mess with it once it’s working. I’ll keep your tips in mind in case the next reset is back to the old behaviour. Thanks for now!

I don’t believe anything related to the remote has changed in the stable releases in quite some time. If your running test builds there was a change that affected remotes that were sold in the last few months but should have only had a noticeable effect for someone who has changed their keyboard language to certain non English layouts and wouldn’t have affected the ‘back’ button.

Ok, new update, problem’s back: After reboot the remote is working EXCEPT the “back” key.

I did the routine (power down, unplug, wait, replug, reboot once) again, and the remote is working in full once more. Ok, if the fix is this reproducable - never mind, I can live with that. Still - curious. :slight_smile:

I still don’t have any more of a clue than when you first posted this and there have been no other reports of similar behavior.

We haven’t changed anything in a very, very long time.