Remove Apache2 and recover Chorus webserver

I installed Apache2 to my raspberry pi model b to see how it worked on a low powered device. When I tried to access my Chorus webserver the following day I instead got apache’s default webpage. I tried to remove Apache2 using this answer, but I still get the default webpage.

How do I get the Chorus webserver working again? Removing apache is not a problem although I have tried.

Have you rebooted after you removed apache?
What is systemctl status apache2 saying

Yes, I have rebooted.

systemctl status apache2


* apache2.service
Loaded: not-found (Reason: No such file or directory)
Active: inactive (dead)

Problem remains.

Ok, how did you install apache in the first instance?
What does ps -aux | grep apache return?

Which port do you have Chorus running on? Can you temporarily change it to check if it works on that?

To install apache I used this tutorial, so:

sudo apt-get install apache2 -y


ps -aux | grep apache


osmc      1924  0.0  0.3   2640  1408 pts/1    S+   11:07   0:00 grep apache

I’m running Chorus on port 81. I just figured out I can access Chorus on 192.168.1.??:81. Fantastic! Can I work with this to access Chorus on 192.168.1.?? as this would be preferable.

This indicates clearly that there is no Apache running on OSMC. So if you get the default Apache page it must come from another machine.

Regarding your question about Chorus access. Not sure how you accessed it before but if you run it on port 81 you have to indicate that port behind the IP. If you don’t want that you need to run it on port 80 (for http)

In case anyone has the same issue. I couldn’t change the webserver back to port 80. Fortunately I had an img of the sd card saved elsewhere and I restored that. This illustrates the importance of having a backup.

In conclusion, backup frequently!