Replacing the USB RF Receiver?

Hello,

I think my USB RF receiver for my vero 4k remote is dead.

No light anymore.
I tried the re-pairing methode : no success.
I tried to connect it on my PC : nothing happened.
I previously checked that my remote was ok (testing with a new battery)

Where could I find a replacement dongle ?

Regards

The dongle doesn’t have a light.
Please post a log when the dongle is attached, and show a picture of the dongle you are using so we can confirm you’re using the correct receiver.

Hi,

Here are my uploaded logs : https://paste.osmc.tv/ahokopakuh

And the pic of my dongle/remote

thx

The dongle is being detected just fine:

Jul 07 16:13:56 vero kernel: usb 1-2: new low-speed USB device number 2 using xhci-hcd
Jul 07 16:13:56 vero kernel: usb 1-2: New USB device found, idVendor=2252, idProduct=1037
Jul 07 16:13:56 vero kernel: usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Jul 07 16:13:56 vero kernel: usb 1-2: Product: USB Keyboard Mouse
Jul 07 16:13:56 vero kernel: usb 1-2: Manufacturer: HBGIC Technology Co., Ltd.
Jul 07 16:13:56 vero kernel: input: HBGIC Technology Co., Ltd. USB Keyboard Mouse as /devices/c9000000.dwc3/xhci-hcd.0.auto/usb1/1-2/1-2:1.0/0003:2252:1037.0001/input/input2
Jul 07 16:13:56 vero kernel: hid-generic 0003:2252:1037.0001: input,hidraw0: USB HID v1.10 Keyboard [HBGIC Technology Co., Ltd. USB Keyboard Mouse] on usb-xhci-hcd.0.auto-2/input0
Jul 07 16:13:56 vero kernel: input: HBGIC Technology Co., Ltd. USB Keyboard Mouse as /devices/c9000000.dwc3/xhci-hcd.0.auto/usb1/1-2/1-2:1.1/0003:2252:1037.0002/input/input3
Jul 07 16:13:56 vero kernel: hid-generic 0003:2252:1037.0002: input,hidraw1: USB HID v1.10 Mouse [HBGIC Technology Co., Ltd. USB Keyboard Mouse] on usb-xhci-hcd.0.auto-2/input1

Do you see a blue light on the front of the remote when you press a button?
Can you double check the battery? We’ve had a series of returns recently that were simply just due to dead batteries, and the customer using an equally dead battery.

Sometimes dongles go bad but what I don’t want to do is send you a replacement dongle when the remote is indeed the issue.

Can you also let me know your order #?

Many thanks

Sam

I tried with 2 brand new batteries (CR2032 3V) : no blue light…

My order is #8119 (2 august 2017)

thx again for your time

Please email support@osmc.tv or raise a ticket via myosmc.com/support and I will sort this out for you.

Sam

email sent :wink:

I received this today and have tested this for you. After using a new battery I couldn’t find any issues with the remote.

There was no battery in your return so I couldn’t check what batteries you were using or if they were healthy.

I’ve sent some details via the ticket system and returned this to you with a new battery.

Sam

Sam,
You were totally right about the battery.
Thank you again for your time and your patience !

1 Like