Resample Audio

Hi there.
I’ve recently bought a new Vero 2 and so far, it seems pretty nifty.
However, two big issues for me:
I have many PAL DVD extracts of American shows/movies, which have unfortunately had the audio resampled, so everything is a semi-tone higher.
I’ve been using a Raspberry Pi for years and it allows resampling of the audio to match the display refresh rate, which I’ve set to 24fps.
However, there doesn’t seem to be the option for this in Vero.
I’ve had a quick look through the forums and cannot find much in the way of a solution.
I’m hoping there is a way to do this, otherwise this device may not be used.

Also, my library is on a Sql database, which works on many other devices, but for some reason, when I go to import the library, it doesn’t seem to like it.
Again, hopefully it’s possible to overcome this issue.

Many thanks in advance.

Alex.

Hi

Semi-tone pitching drives me nuts. In the UK, it’s often used to speed up a TV show to sneak in longer ad breaks.

What options are you selecting in particularly? I’ll check it out on Vero 2.

If you’re using MySQL, you just need to configure your database settings. This can be done in advancedsettings.xml, but that can be technical. You can achieve the same by going to My OSMC -> Network -> MySQL

Hope this helps

Sam

Hi Sam
Thank you so much for the speedy reply!
I’m so happy someone else shares my pain with the pitching of shows!
I’ve never thought of it from an ad perspective. Sneaky.
I’ll take some comparative photos tonight when I get home from work to show the menu settings.
It looks like the option is missing in Vero, something like resample audio to keep it in sync.

I’m using Mariadb on my Synology to host my database.
Whenever I set up a new Kodi/Openelec/Osmc, I just drop the advancedsettings.xml file into the
userdata folder, reboot the device and voila, everything’s there.
But that’s not happening now.
Just so I’m not going crazy, I put the same xml file into the userdata folder on my Mac, loaded up
Kodi, and sure enough, the library was there.
I even renamed the library name in the xml file just to see if it was using the wrong name,
but when I logged into phpmyadmin, it had created 2 new tables, so I know it can see the db.
I then thought I had to import the library from an existing install.
But when I went to import, it’s as if it couldn’t see the video xml file. Very strange.

I hope it’s possible to get all this sorted because it’s a lovely device and I can’t wait to get it working! :slight_smile:

Photos for the comparison coming this evening.

Thanks again!

Alex.

Provide Debug enabled logs if you need help!
And maybe open a new thread as it would not be related to your resample audio topic.

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Our wiki contains detailed steps for providing the relevant info we need to help you.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request

You know you might need to enable advanced or expert level settings to be able to see these options?

Thank you, I’ll create a new thread for the database.

@ActionA, thank you, but I’m afraid I’ve already set mine to expert level.

So, this image is Vero:

And this image is from my Raspberry Pi:

Highlighted is the A/V Sync method which doesn’t exist in Vero. This way, my video plays at 24fps and the audio resamples at the lower pitch.

Is passthrough disabled or enabled?

It was disabled, but I enabled it to test. Still no joy.
FYI, it’s disabled on the Pi.

The PLL adjustment option is a Pi-only feature. As one of the Kodi developers also works for the Raspberry Pi foundation, they have implemented this in the Pi’s firmware. I believe the intention of this feature is to allow the PLL to drift to sync audio for 24p content, avoiding a slight stutter once every 41 seconds (23.976 vs 24hz) rather than to counteract semi-tone pitching adjustment. This is for TVs where the refresh rate cannot be adjusted to a fractional one.

The good news is that all you should need to do to avoid this is enable ‘Adjust refresh rate’ in settings. I have some improvements coming in the next update which will improve this further. The next update will come out this month.

I’ll keep an eye out for the database thread.

Sam

That’s disappointing.
I had hoped the Vero could do this and I’m surprised that the Pi, which is a quarter of the price, can.

The option “Adjust refresh rate” is the opposite of what I need, as I need to lock it to a refresh rate,
and have the playback match the display refresh rate and have it resample the audio to the correct pitch.

I shall await the update later this month and test again.
Thanks for your help.

The Pi is a little different, it’s not the price point, but rather the fact that a Raspberry Pi developer works on the Kodi project and Pi firmware, so was able to implement this feature.

My understanding is you just wish to avoid the semitone pitch. This should be fine with adjust refresh rate on and AC3 transcoding.

P.S: a Pi with all the accessories is not a quarter of the price, but let’s leave that one…

Let us know about the SQL issue too so we can look at this

Sam

Hi Sam
I understand your meaning regarding implementing the feature.
I shall test the “adjust refresh rate” with ac3 transcoding and let you know.

You’re correct about the price :wink: I was just focusing on the Pi itself, not including everything else required.

I’m not working this weekend, so I’ll be looking into the SQL issue, so hopefully we’ll get that sorted!
If not, I’ll create a new post :slight_smile:
Thanks again.

Alex.

Excellent, let me know how you get on.