Rescanning TVHeadend With No Network Connection

I have recently configured a RPi 3B (v 1.2) with OSMC (running KODI 20.1) and TVHeadend 4.2.8. My intention is to use this for video/movies (stored on a 256G thumb drive) and tv viewing at our remote camp. All software installed, configured, and operates fine at my primary residence. At my remote location, I am able to receive OTA TV broadcasts, but do not have access to internet or wifi.

Original configuration of TVHeadend installed in OSMC required login using a separate networked computer. When I relocate the device to my remote location, I’ll need to rescan for local channels. Can someone guide me through how this process can be accomplished without internet, wifi, or network connection?

Enable Hotspot on the Pi (MyOSMC - Network) or alternatively make your mobile phone a hotspot.

It is my understanding that TVHeadend/OSMC will not work remotely using my IP. Rather OSMC needs to be directed to localhost/ True?

If Kodi and TVHeadend run on the same machine then yes locahost should be used to communicate

Thanks fzinken. I was able to attempt a TVHeadend rescan this past weekend. At my remote location, I was able to activate an OSMC ‘HotSpot’. The ‘HotSpot’ was visible on my tablet, and I was able to logon. My assumption was (as recommended) that as OSMC and TVHeadend are loaded on the same computer, TVHeadend could be accessed through IP However, I was unable to access TVHeadend through For some reason, my TVHeadend instance thought its’ IP address was While I was able to logon to TVHeadend using this ( IP, a channel rescan was unsuccessful. I fear some parameter is misset.

Subsequently (back home), I note in TVHeadend (Status>Users) both my home (network) IP and are listed as users. However, both have a red stop sign containing a white x. Does this indicate ‘inactive’? If so, how do I activate. How can I get TVHeadend to communicate with OSMC through

Misunderstood function of IP Seems to be working now.