Resolution and sound issues with new 4k+, Was fine with Pi II


I have taken delivery of my new vero 4K+ today.

I have removed my old RasPi2 and demoted it to the bedroom.

The vero will not accept any res above 720p (blank display and switches back)

Also no sound with any content in any res. no clicks from the UI

Connections as follows HDMI->HDMI SPLITTER->Pio LXDP5090

With ras pi plugged onto the end of the same cable, all is well. 1080p output on the Pio and analogue and pass-thru audio with no issues.

Things tried so far Ignore HPD (no change)

Logs are here:


Does it work when connected directly to the television?

Yes it does.

I need the splitter to work though, it is part of my Hyperion ambilight.

Hi Jeff,

Your display is advertising support for 1080p.


Can you let us know the make and model of the splitter?

Audi shows only 2 channel PCM is supported:

PCM, 2 ch, 32/44.1/48 kHz, 16/20/24 bit

We can give advice on how to force an EDID.
What happens specifically when you set to 1080p?


Hi Sam,

Yeah, I know it says it will support 1080p@60Hz, but for some reason it just does not work with the Vero when it “just worked” with the Pi.

It just does not sync when I set 1080p Black screen, no display. I then reverts to the prior resolution.

If I connect direct to the TV and set the res. to 1080p and then shutdown, replug via the splitter and reboot I very accoasionaly get a distorted greenish screen, but 90% of the time i just get black.

This is the cheapie splitter

(it didn’t say 3D or 4K when I bought it, I don’t think it is for a minute, and as the display is only 1080p I think it should still be fine for me i think)

Is there any way i can grab all the HDMI “settings” when synced with the direct cable and force then when via the splitter?

Of can I replug the Pi and get the settings from there?

Please revert this to default, connect the vero direct to the TV, re-boot and post the logs from that so we can see your TV’s proper specs.

reverted all video settings to default.

cabled direct to TV


logs at

1 Like

You mention passthrough audio above but the TV says it supports only stereo PCM. Does it actually support DD?

It just has a sound bar. I am happy with stereo pcm.

It does support DD (my humax YouView box uses it) but I really don’t care as the speakers are 2 channel only.

You should probably turn off passthrough, then. Apart from that, I can’t think why you would not have sound. As for the 1080 problem, try setting the resolution to 1080i.

I’m working on a better solution for you.

Video syncs reliably at 1080i

No audio even with passthru disabled :upside_down_face:

Let me get this straight.

  • The sound bar is plugged into the TV: via analogue, TOSlink, digital coax or what?
  • Do you get sound with the Vero plugged into the TV direct?
  • Do you get sound if you don’t use the soundbar but use the speakers in the TV (are there any or do you have to connect speakers to the speaker terminals?)

OK I dragged all the cables out and reseated everything.

I now have sound.

FWIW, the “soundbar” is just the TV own speakers. (TV was bare panel when new,) speakers were an extra and just plug into that back of the panel via 2x speaker wires, into push terminals and mount under the panel. Looks like a soundbar, but in modern parlance it is not really a soundbar.

Still maxed out at 1080i for display.

1 Like

Yes. Are you sure the Pi doesn’t have the same limitation? If it really is sending 1080p then at least we know it’s possible.

I’ll try the pi again tomorrow, as wife is sleeping in the bedroom now.

I am pretty sure it was running at 1080p,. But certainly worth confirming.

Thanks for all your support to date

Yes, I just tested that. Pi doesn’t care about some of the EDID information that we have to care about on vero for 4k modes. If you want to get everything working as if the splitter wasn’t getting in the way, some self-assembly is required. Try this:

  • with HPD enabled, plug vero direct to TV in the same HDMI socket you are using for the splitter output
  • ssh into vero and type the following:
    echo save bin /home/osmc/edid.bin | sudo tee /sys/class/amhdmitx/amhdmitx0/edid
  • unplug vero from TV and re-connect it through the splitter
  • disable HPD and type:
    echo load /home/osmc/edid.bin | sudo tee /sys/class/amhdmitx/amhdmitx0/edid
  • check it’s working as expected, then add the following line to /etc/rc.local:
    echo load /home/osmc/edid.bin > /sys/class/amhdmitx/amhdmitx0/edid
  • reboot and check it’s still working

I have no idea what this will do to CEC but let us know if that’s a problem.