Resolution question

Hi, Sorry if covered elsewhere. I have 2 questions:

  1. Which resolution is best for the Vero 4k settings - using a 50 inch Panasonic HDR tv? (EX750) - would it be 3840 or 4096?

  2. Some of my 1080p and 4k files suffer from motions blur and pixelation - maybe this is called tearing? Not sure of the terminology but only happens 4 or 5 times per movie - normally when there is close up high speed motion. This happens when both 3840 and 4096 resolutions are selected. Is there any way I can stop this happenning, either on my tv or the Vero? I have all the motion controls turned off on the tv.

Thanks

Hi,

Set the resolution to 1080p, and set adjust display refresh rate to always or on start and stop. Its under player, video in the settings.

Your TV should do a better job of scaling the gui than kodi does and when you play a movie it will auto adjust to the correct resolution and you should no longer see the motion blurs and pixelation.

Thanks Tom.

Thanks for the reply - but won’t that mean that 4k content coming from the Vero will not be in 4k quality / resolution?

Hi,

With adjust display refresh rate option set as described, when playing a movie the resolution will change up to 4k and to the correct refresh rate as well; when you stop the movie the resolution reverts back to 1080p.

Thanks Tom.

1 Like

Ah right, I’ assumed incorrectly that 1080p was the maximum if set to that.

Thanks very much I’ll give that a try.

1 Like

Hi. I tried this last night but whenever auto adjust refresh rate is set to on, it results in a black screen drop out with audio only. No idea if this is a Vero issue, Kodi issue or tv issue, but it’s a new TV.

Any ideas? thanks.

What about if it’s set to Off or Always?
No problems when set to Off with a LG TV here.

The blackouts don’t happen when it is set to off. Only when set to always or start/stop. But if I set it to off and my output is 1080p - what resolution will I be seeing 4k content in?

just the gui will be 1080.

if you start a movie the resolution will change to the original resolution of the movie (4k etc.)
If you stop the movie, your gui will be shown in 1080p again

Hi,

Can you please provide logs showing the blackouts, more details can be found here:

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Thanks Tom.

1 Like

Not so. To get 4k you have to set adjust refresh rate on.

AFAICT.

Nope. Besides, it’d be quite confusing/misleading to have the setting for refresh rate also have an influence on resolution. Try it for yourself.

https://kodi.wiki/view/Settings/Videos#Playback
https://forum.kodi.tv/showthread.php?tid=322594&pid=2656484#pid2656484

Testing showed me I was wrong and indeed the adjust refresh rate has to be set to something else than off to enable Kodi switching from FullHD output to UHD output. Sorry, my bad.
On a side note, I think it’s funny the TV’s upscaler does such an awesome job I couldn’t tell until now. If you own a LG TV, point at the screen’s upper left with the remote and click, it will display aspect ratio, resolution, HDR/SDR, sound format, and BT.2020.

I remember now. My problem is my AVR does not do 50/60Hz but the TV does. So vero will re-sample 4k/50Hz to 1080p/50Hz instead of 4k/25Hz. If I set the GUI to 4k/25 the video will play at that but I get micro-stutters on slow pans and moving objects. Like you, I can’t tell the difference between the resolutions!

@smallclone just press the i button on the Panny remote to see the resolution/refresh rate.

I’m pretty sure that if auto refresh rate is set to off, and 1080p is selected then everything on my TV is 1080p max.

At the moment, the only way I can get 4k resolution without black screen dropouts, is to select 3840 or 4096. But that leads to these glitches in fast movement most of the time, hence this thread.

I will try and upload a debug log tonight. I really hope this isn’t a faulty tv.

Are you able to set the GUI refresh rate to the same as the video? I assumed I was getting glitches because it was converting from 50Hz to 24Hz. My TV is an EX700 which should handle the same signals as yours.

I’ll check later.

In the meantime - could this be a HDR Autoswitching issue? Is that supposed to be ticked?

Hi,

I would try disabling it for now and see if the issue continues.

Thanks Tom.

Hi,

I did a bit of testing last night.

-Outputting the Vero to 1080p with refresh rate set to start/stop does give the best performance results as the judder is less. Unless my eyes are deceiving me though the 1080p content isn’t getting as much upscale as when it’s set to 4k but I can live with that.

-However, the refresh rate auto change does sometimes result in a blackout on my screen - but I tried creating a debug log - but it doesn’t occur at set times. It seems a bit random. One thing I noticed is that the blackouts normally occur just after I have fast forwarded on the Vero. If I let the content play from start to finish it is normally fine. I will keep trying to create a debug log but it is difficult to reproduce the error.

-The “tearing” I mentioned seemed to be created by a setting on my panasonic tv called “intelligent frame creation”. When set to high it is masisvely smooth and I get the “soap opera effect” but also produced motion blur, so I guess it’s a judgement for me to make here.

One question I have is that there are two 1080p output settings - one with 60 fps and one with a lower one - so which do I choose?

Thanks

That’s just for the gui, so if it looks ok leave as is.

Thanks Tom.

1 Like

I have mine resolution set to 3840/60fps and auto refresh rate is set to off, everything plays just fine without any issues…