Resolution question

I’m pretty sure that if auto refresh rate is set to off, and 1080p is selected then everything on my TV is 1080p max.

At the moment, the only way I can get 4k resolution without black screen dropouts, is to select 3840 or 4096. But that leads to these glitches in fast movement most of the time, hence this thread.

I will try and upload a debug log tonight. I really hope this isn’t a faulty tv.

Are you able to set the GUI refresh rate to the same as the video? I assumed I was getting glitches because it was converting from 50Hz to 24Hz. My TV is an EX700 which should handle the same signals as yours.

I’ll check later.

In the meantime - could this be a HDR Autoswitching issue? Is that supposed to be ticked?


I would try disabling it for now and see if the issue continues.

Thanks Tom.


I did a bit of testing last night.

-Outputting the Vero to 1080p with refresh rate set to start/stop does give the best performance results as the judder is less. Unless my eyes are deceiving me though the 1080p content isn’t getting as much upscale as when it’s set to 4k but I can live with that.

-However, the refresh rate auto change does sometimes result in a blackout on my screen - but I tried creating a debug log - but it doesn’t occur at set times. It seems a bit random. One thing I noticed is that the blackouts normally occur just after I have fast forwarded on the Vero. If I let the content play from start to finish it is normally fine. I will keep trying to create a debug log but it is difficult to reproduce the error.

-The “tearing” I mentioned seemed to be created by a setting on my panasonic tv called “intelligent frame creation”. When set to high it is masisvely smooth and I get the “soap opera effect” but also produced motion blur, so I guess it’s a judgement for me to make here.

One question I have is that there are two 1080p output settings - one with 60 fps and one with a lower one - so which do I choose?


That’s just for the gui, so if it looks ok leave as is.

Thanks Tom.

1 Like

I have mine resolution set to 3840/60fps and auto refresh rate is set to off, everything plays just fine without any issues…

This is not ideal.

1 Like

Sam, can you help me with resolution switch. In my xbox one plex app all my files DVDRip,720p,1080p plays in 3840x2160/60fps and actual 2160p files switches to original 24,23fps. I’m trying to do same in vero 4k but vero switches everthing to 24,23fps . If i set refresh rate to off than 4k HDR plays in 60fps but than HDR color is to faded in 60fps. Is there any solution to keep DVDRip,720p,1080p in 60fps and 4k HDR in original FPS.

Set the resolution to 1080p
Enable Adjust Refresh Rate

Thanks for replying, i did try that but than files that are DVDRip,720p,1080p are switching to original FRAMES and i’m trying to keep them in 60fps

Why do you want to play these titles at 60fps?

In my samsung tv there is a option called PC and it gives me best picture calibration but it only activates if its in 50fps and 60fps.

Watching 30 and 24fps video at 60 FPS will probably have other negative side effects

I have tested 23fps and 24fps in 60fps and it plays without any stuttering.

If you whitelist just the 60fps modes at 1080p and 720p it should play in those.

I tried whitelist 720p/60, 1080/60 but then 2160p plays in 1080p/60 so I I add 2160p23 and 24 then everything plays in 2160/24

Can you post some logs, please? Kodi have been working on changes to whitelisting which we can incorporate but I’m not sure yet what they are trying to achieve.

(I know it’s an old topic, but I think I should add some information in case people end up here searching, as I did.)

I realized my Vero 4K+ downscales 4K videos to 1080p for displaying on my 4K TV (and that the TV does such a great job upscaling it, I hadn’t noticed the problem for several days). Then I learned in this topic that “Adjust display refresh rate” setting should be set to “Always” instead of “Off”, however it didn’t help me first and I spent another hour looking for a solution. Then I restarted Vero, and the problem was solved: my 4K videos are displayed in full resolution now.

So just remember you might need to restart the device after enabling the “Adjust display refresh rate” setting. Hope this will help. :slight_smile:

The adjust refresh rate option does not require a restart so there may have been some other setting you had in play that did. Just for reference the following is our current recommended configuration.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.