[RESOLVED] Frequents Kernel Freezing: OSMC - PI2

Device: Rasp Pi 2,
Installation media: SDcard, USB Hard Drive
Connection: Wired
Power Supply Type:
Power specs: 5V 200mmA
Storage: Seagate 5T USB hard-drive
Peripherals: USB Hard Disk, Bluetooth Logitech Keyboard K400r with bluetooth dongle
OSMC version: VERSION_ID=“2015.08-1”

Hi All,

I am currently experiencing frequent kernel freezing, I am concerned because the O.S. is running from an external HD which works also as “NAS” and when the PI2 is freezing nothing works and I obligated to remove the power supply. Unfortunately seems the combination “alt+stamp+REISUB” deoesn’t work from the bluetooth dongle of the keyboard. I started to experience this freezing when I installed from the “app store” Transmission.

The logs I posted below are from the last freeze, in particular during the last block the mediacenter was been stopped to avoid problems with Transmission but the system has been blocked the same.


Thanks in advance,


Does it only freeze when transmission is downloading?


I am not pretty sure but probably it happened also a couple of time without Transmission working, usually happens after some hours of inactivity (3 or more).

I will stop to use Transmission for a while and reporting any issues.



Hi, after a couple of days without problems today when I came to home I had another freezing.
I left the PI2 on this morning without transmission so my mother in law could put some Italian cartoons to my son instead the English toons by Comcast, when I went to shutdown the PI2 I found glitch on the graphics and the cursor frozen.

Has been impossible uploading by OSMC the log because it weight 157 MB, so something is not working properly. I uploaded the log by gdrive:



There is an update that fixes the oversized log issue and performance so first you need to update. After if the problem still occurs try turning off screensaver and upload a log.

I updated OSMC but I received an error to an UNKNOW PACKAGE tried to install… :frowning:

This is the new log: https://paste.osmc.io/yayeregefu

I don’t see any apt errors, can you ssh into your Pi and run

sudo apt-get update
sudo apt-get dist-upgrade
sudo reboot

and see if any errors occur

Hi, thanks for your interest.

I launched those command and, luckily, no errors:

osmc@osmc:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... The following packages were automatically installed and are no longer required:
libflac8 rbp2-image-4.1.3-2-osmc rbp2-image-4.1.5-1-osmc
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Any way this alert was been pretty weird.

Just another quick question, do you think is the screen saver the cause of those blocks?

Hi All,

another block, all the time the screen blinking with this emoticon :(, impossible login on the consoles, every time I tried to put the username the screen blinked to this the emoticon screen. Pretty annoying.


You still have turbo overclock enabled. That will not work reliably for many Pi’s.
Please disable before reporting crashing.

Indeed. My Pi 2 cannot run in turbo mode either - I see random freezes if I try. Drop your overclock back to “normal” then retest.

Hi thanks for your help and replies, I should check because I enabled the soft overclock but I don’t remember if I enabled the “turbo” mode as well. As I far I know I always read to do not enable this feature.

Any way I will remove any overclock and I’ll let you know, thanks!


Hi all, many thanks for all your help, until now I haven’t had any freeze just a block of Kodi but it was able to restart itself.

Below the latest logs:


Hi guys, I enabled Transmission to test the system and until now (a couple of days) I have never had any freezing even watching a movie, using Transmission and copying a heavy files from my computer the OSMC usb hard drive, I will take another couples of day to close this thread, thanks to all!

Disclaimer:- I haven’t read the entire thread.

Is it possible that a spindown of the drives in the NAS, or a NAS sleep state, could be the cause of the RPi2 freezing?

I don’t think so, after removed the overclocking I never had any other issue, thanks to all!