[RESOLVED]How it's possible to remove source for addons ? I have a SMB source and i can't delete it.. help

I have OSMC RC3 0.9.9 updates 5 minutes ago (on my Raspberry PI2) but i have this problems… on Installation Source for zip addons in the list it’s present a SMB source ( and i don’t figure how it’s possibly to remove it!

I have try to found it on “File Manager” but there’s no source here… i have tryed to use C on keyboard for context menù for modify it or similar but apparently there’s no mode to delete it…

If it’s possibly help me…

I can also try, if someone can post me a suggestion, try to modify some file by pc using telnet or similar…

So what device on your LAN is And what is the necessity for removing it?

1 Like

This is the main problems… on my LAN it’s no more present:
I don’t remember how i can add this source here… but now i choose:
Home -> Preferences -> Add-ons -> Install from zip

Now it’s present the default value:

  • Browser zero conf
  • Home
  • etc etc

At end of this list i don’t know how i have add this and i have:

  • smb://

If i press enter on it… i obtain error on host… at this point from main list i have tryed to deleted it but i can’t…

On OSMC i have installed and now it’s running the FTP Server… now i can access to my Rasp from my PC using filezilla:
If you can suggest to me what’s the exact file it’s stored this configuration i thinks i can try to edit manually from pc…

Then don’t press it!

It won’t hurt anything. If it wasn’t config’d in sources.xml (file manager) then I’d chalk it up to the borked implementation of SMB between Windows and Linux that have been present forever…


ok… i know… and there’s not exist a mode to delete this entryes ?

I have checked on “File Manager” and there’s no addictional sources…

Where it’s stored this “sources.xml” ?? Using FTP by FileZilla on my pc i can edit manually ?


But if you aren’t seeing it in file manager, then I doubt it’s in sources.xml.

1 Like

mmmmmmmmmmm… .kodi it’s a hidden folder ?
I cant found it using telnet… or ftp… strange…

Yes, any file or folder that begins with “.” is hidden in linux.

1 Like

mmmmmmmm… i try to enter it from ftp… or i need to found edit from telnet

Your ftp client (filezilla, winscp, ???) should have a setting to show hidden files/folders.

Or simply

cd /home/osmc/.kodi
1 Like
        <default pathversion="1"></default>
        <default pathversion="1"></default>
            <path pathversion="1">smb://</path>
        <default pathversion="1"></default>
        <default pathversion="1"></default>
        <default pathversion="1"></default>
            <path pathversion="1">http://shadowcrew.info/shadows/</path>

mmmmmmmmmmm… this is the file. it’s my pc… and this is the smb for video section… the shadowcrew it’s a source i have add by file manager and there is appared from “Install from zip” correctly but this “smb://192…210” it’s no present.

I don’t remeber how i have add this… at this point or i need to force a refresh or sources for similar operation…

Interesting… inside this folder it’s present a mediasources.xml contain this:

        <location id="0">smb://</location>

Try to found how i can disable this voices… i try to edit whit another value for test…

I suspect it’s a UPnP/DLNA/Airplay (or similar) advertisement from another device on your LAN.

1 Like

no… i don’t have any device on my lan whit this ip…

I have renamed mediasources.xml to mediasources.old…

The “” it’s no more present on “Install from Zip”… but i don’t thinks i can delete this file…

Go ask http://forum.kodi.tv what populates mediasources.xml because I don’t know. The IP is certainly on your subnet… Possibly by coincidence, but alas…

Sure you can delete the file. But it’s quite possible restarting Kodi will cause Kodi to re-create it.

1 Like


1 Like

Interesting… now i have tryed to modified this to:


Now try to delete the files…and restart osmc :smile:

Lol… it’s possibly it’s a residual file from RC1… or my mystake…

What’s a stupid problems… now it’s resolved…

Can modify the TITLE to Resolved or simply close the entiry thread…