(Resolved) Hyperion : Disable autostart...?

Hello (first of all, sorry for my bad english…),

Is it possible disable the autostart of Hyperion ?

To explain myself, I use Hyperion on a Raspberry with OSMC and my
Philips Hue. Hyperion works perfectly, and I can enable or disable
Hyperion using my TV remote (thanks to this tuto How to: turn Hyperion on/off using your TV remote. | nadnerb.co.uk).

However, I would like to prevent Hyperion to automatically starts
with OSMC (to prevent my Hue to change their color or to switch on
during the “boot sequence”), and I would like to manually starts
Hyperion with the Remote just when I want to use it (in launching the
.sh init.d script…?).

I did not manage to do this. Any help ?

Thank you !

systemctl stop hyperion
systemctl disable hyperion

Thank for your answer.

If I use these commands, the service (Hyperion) will be disabled until the next reboot ? Or until I manually restart it ?

disable is disable then its turned off permanently

stop is until next boot

for more info google systemctl command

I have this error message when I try to disable Hyperion

update-rc.d: error: hyperion Default-Start contains no runlevels, aborting.

Do you know why ?

Thank you

Probably the wrong service name. Make sure you are using the correct name for the service.

no idea why, for me it works without issues

make sure that hyperion installed correctly

It’s OK. It seems that I had a problem with symbolic links…

I just reinstalled Hyperion and follow this tuto Home · hyperion-project/hyperion Wiki · GitHub, and now it works perfectly.

Thank you very much !

1 Like