[Resolved] Update error : Unknown package (yeah me too)

Hi there,

I can’t update my OSMC on my RPi2 .
I tried autoinstall and manual install.

Here are the logs : http://paste.osmc.io/henocetezo


You appear to have tried to update twice, and the first time the update either hung or was interrupted by your Pi crashing or having the power pulled:

Preparing to unpack .../rbp2-mediacenter-osmc_16.0.0-1_armhf.deb ...
Unpacking rbp2-mediacenter-osmc (16.0.0-1) over (15.2.0-8) ...

Log started: 2016-02-22  20:14:08
Preparing to unpack .../rbp2-mediacenter-osmc_16.0.0-1_armhf.deb ...
Unpacking rbp2-mediacenter-osmc (16.0.0-1) over (15.2.0-8) ...

You don’t say whether you are seeing any problems beside the error message ? Is Kodi still loading ?

I tried again and this time it say no update available :o
May be the manual update worked even if there was errors.

The error was probably just a syncronisation error on our APT servers. Normally this will resolve itself within an hour.

Nah, i had this error during some weeks.

The same error can have many different causes. That’s currently the error that My OSMC reports for any “unknown” error when checking for updates.

Hey guys !

Another update came up and auto-updater still do “unknown error”.
Seem like it work only when doing manual update.


A me-too from my side.
I have this for a while now. Everytime I get a message that updates are available and I try to install them from the gui, I get his error
Error installing: (unknown package)
Please report this on the OSMC forum.

When I log in over ssh, I get
The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Fri Mar 4 12:43:42 2016 from
Updating APT cache. Please be patient.

—After that last line, it takes about a minute before the prompt appears.
Now I continue with an dist-upgrade:

root@kodiliving:~# apt-get dist-upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

----so there seems to be nothing to upgrade??

Sadly, I had to make a fresh install to resolve the problem …