Restore source.list of raspberry Pi (1)

Hi,
First of all sorry for my English. I have made a quick search but I’m afraid what I have done is quite strange and I can’t find the same exact problem. And I really don’t wont to get the system worst that it is now.
Problem: I wanted to install some packages to get dispmanx_vnc working in my sister rPi1. The apt-get couldn’t find them so I copy the source.list of my rPi2 to the source.list of my sisters. Update, upgrade, get error with NOPUBLIC_KEY, I began trying to solve them adding keys. Get nervous, clean all lists, apt-get update, upgrade, restart rPi several times …finally I realized the problem was that rPi2 and rPi1 don’t use the same repositories and also, mine is in Jessie and hers is en 15.2. My sister actual osmc info is this one:
osmc@osmc:~$ grep Kodi .kodi/temp/kodi.log | head -3
16:24:57 10701.454102 T:3025179184 NOTICE: Starting Kodi (15.2). Platform: Linux ARM 32-bit
16:24:57 10701.454102 T:3025179184 NOTICE: Using Release Kodi x32 build (version for Raspberry Pi)
16:24:57 10701.454102 T:3025179184 NOTICE: Kodi compiled Nov 29 2015 by GCC 4.9.2 for Linux ARM 32-bit version 3.16.7 (200711)
osmc@osmc:~$ grep VERSION_ID /etc/os-release
VERSION_ID=“2015.12-4”
osmc@osmc:~$

And at this moment the content of her source.list is:

osmc@osmc:~$ cat /etc/apt/sources.list

deb http://ftp.debian.org/debian jessie main contrib non-free
deb Index of /debian jessie-updates main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
deb http://apt.osmc.tv jessie main

What should I put inside source.list or what can I do to recover the very initial state? If there is no possible solution I’m afraid I will have to go to her city and make a clean installation XD.

Thank you very much.

osmc@osmc:~$ cat /etc/apt/sources.list
deb http://mirrordirector.raspbian.org/raspbian jessie main contrib non-free
deb http://apt.osmc.tv jessie main

Nice! It worked. Thank you very much!

Well, it worked but when doing dist-upgrade it gives me this. I have try apt-get clean, apt-get autoclean , but same result :(.

Preparing to unpack …/rbp1-image-4.4.1-1-osmc_1_armhf.deb

Examining /etc/kernel/preinst.d/
Failed to process /etc/kernel/preinst.d at /var/lib/dpkg/tmp
.ci/preinst line 361.
dpkg: error processing archive /var/cache/apt/archives/rbp1-
image-4.4.1-1-osmc_1_armhf.deb (–unpack):
subprocess new pre-installation script returned error exit
status 2
Examining /etc/kernel/postrm.d .
Failed to process /etc/kernel/postrm.d at /var/lib/dpkg/tmp.
ci/postrm line 291.
dpkg: error while cleaning up:
subprocess new post-removal script returned error exit stat
us 255
Errors were encountered while processing:
/var/cache/apt/archives/rbp1-image-4.4.1-1-osmc_1_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
osmc@osmc:~$

Hi @wilcome,
did you ever find a solution to your last error codes. Seems like I am getting the same on update to rbp1-image-4.4.6-3-osmc_3_armhf.deb after correcting the sources.list

Try again as it might have been a temporary connection issue, otherwise provide logs so that we can check.

Hi there! It was impossible for me to solve that problem so I ended up with a clean installation :cry: (moving to my sister home logically).

Thanks guys for the quick reply,
Tried again a few times (interrupted by reboots and some more reading - without result) - always with apt-get clean andthen update and also once apt-get autoremove (which just told me that the rbp1-image-4.4.6… is heavily corrupted and i should reinstall it before removing (vicious circle), but now consistently getting that same error.

Logs are here: http://paste.osmc.io/acodofegek

Maybe it helps ( but not too confident seeing the segmentation faults in the syslog).

segfault must have a reason.
Either your overclockign or your sdcard/filesystem

Thanks for your help. I ended up reinstalling.
Although removing the standard overclock manually got part of the system to update, the above named file still wouldn’t update and the segfaults appeared more often. In the end it seems there was a slight corruption in the fat part of the sd card.