Restore Transmission torrents after data corruption

There was a power outage yesterday and my Vero4k+ shut down unexpectedly and my external disk got corrupted, I could not mount it again.

So I ran fsck /dev/sda1 and mounted it again with mount /dev/sda1 /media/WdElements and all the files have been restored and it works correctly. But now Transmission is giving me the error for all torrents on WdElements disk “No data found, ensure your disks are connected or use set location”.

The location did not change so the set location functionality doesn’t do anything, I’ve tried to verify local data also but it didn’t do anything. I’ve also rebooted the Vero4k and it didn’t fix the issue.

Is there a way to fix this? Will I have to manually add torrents again? Not sure what the best thing to do here is, but I really want to keep them as I had 70+ torrents that I was seeding.

Did you try stopping and restarting transmission since repairing the mount?

Yes, I restarted the service first and also restarted the Vero device and it did not help.

Just try re-adding the torrents again.

Force re-hash

Found out what the problem was, apparently when I manually mounted my external HDD it mounted it correctly to /media/WdElements, but after reboot Vero automatically mounted it to /media/WdElements_ and there was an empty /media/WdElements folder as well… not sure what happened there, but I fixed it by unplugging the HDD, rm -rf /media/WdElements and plugged the HDD again and it now works fine with Transmission.