Restoring Backup on Vero V - error "failure to reading the file"

Hey everyone,

today my Vero V arrived and I’m absolutely loving the snappyness of it so far.

However I’m not able to restore my backup coming from a Vero 4K+.

Both my Veros show “OSMC August 2023 2023.08-1” as the version and I made sure to update both before backing up.

First I had an issue with writing the backup file on the V4K+ (“backup failed to copy the tar file”) which I was able to fix by rebooting (found the solution for this here on the forum).

I then created a full backup of the system (all toggles in MyOSMC) which came out to about 980MB to my NAS through NFS.

When I want to restore this backup on the Vero V, it just says “failure to reading the file”.

I then created another backup on a USB stick which came out to EXACTLY the same byte-size and tried to restore this on the Vero V, but I get the same error as well.

If I unpack the .tar.gz it has all the data inside, so I’m not sure what the issue is.

Any help would be appreciated!

You could try copying the backup file to the V and see if that gives you success. You might also try excluding the thumbnails in the backup which will make the file a lot smaller and faster to deal with. If all else fails you could also just manually transfer the files from one box to the other skipping the UI based approach entirely (this is what I personally do).

Hey, seems to have been an error on my end.

I have now tried restoring directly from USB instead of from the NAS and now it worked.

So it might have been an issue with my NFS config (although it SHOULD be working in theory :smiley:, but I’ll need to take a look at that again)

Thanks anyway!