Resume point on playback not working

on my Vero 4K+ (V18.6) resume points for video library are not working.
I’m using an user defined advancedsettings.xml with parameters for MySQL. Files are located on windows machine (using smb).

When starting playback, the ‘resume point’ is found (if available). When choosing ‘resume point’, the playback nevertheless always starts from the beginning.

I’m pretty sure, that this behaviour wasn’t there a month or two ago.

Using Kodi on other devices like Android and Windows (with same user advancedsettings.xml), the problem doesn’t occure.
A debug log can be found here.

Do you have any ideas, what went wrong?

I just found this topic, that I didn’t see before. There is a change with v18.6 suspected.

As described in post before, problem occurs only with OSMC and not on other devices.

Can you please upload logs via My OSMC?
Does this only happen with transport streams?


Hi Sam,

you’ll find new logs here.

99% of my videos is TS. But I found an old avi file - there resume point still works.
As mentioned in first post, also TS Videos worked in OSMC in the past, maybe <= v18.5.


I can’t reproduce here, but I can see what the problem is.

Anything I can help with?


Hopefully the issue is now addressed

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

1 Like

Hi Sam,
thanks for feedback.
The change has solved this issue.
Works fine!