RetrOSMC RetroPie Launcher Just Restarts OSMC

I found instructions on how to install RetroPie in an existing OSMC image. Everything via Putty/SSH and Filezilla went off without a hitch.

  1. I got retrosmc
  2. I installed it
  3. I installed the launcher
  4. I created the proper ROM folders from the RetroPie wiki and uploaded all my roms
  5. I got all the proper BIOS files from the wiki and put them in the BIOS folder.
  6. I scraped every system

Everything was set, but when I went to run the launcher in OSMC, it hangs for 10 seconds or so as if it’s working, then the screen goes black and OSMC restarts back to the Kodi menu.

I’m at a loss as to what I could’ve done wrong. Has anyone ever dealt w/ this issue? I tried searching and did not find much of anything.

Thank You in advance for any help you can offer.

Not sure, but wouldn’t this be a thread that matches your search?

In ssh, try this:

sudo systemctl stop mediacenter

This will stop kodi, and you might be able to see any error message from emulationstation which can be helpfull.

To start kodi again, from ssh:

sudo systemctl start mediacenter

Sorry but that doesn’t seem to work. The sudo commands to stop and start the mediacenter worked just fine, but just typing in “emulationstation” in Putty does nothing.

I just get this when I try. Fair warning, I know next to nothing when it comes to Linux commands
-bash: emulationstation: command not found

Ok, I started thinking that maybe Emulationstation just wasn’t installed. The “install retrosmc the easy way” link I found did seem a bit TOO easy. It just asked to get the retrosmc install file, install it and then install the launcher.

But that’s obviously not all I need to do. I ran RetroPie Setup via SSH and went to the core packages. Upon seeing Emulationstation, I installed it. Then I did this and finally got an error

osmc@osmc:~$ sudo systemctl stop mediacenter
osmc@osmc:~$ emulationstation
lvl0: es_systems.cfg file does not exist!
lvl0: Example config written! Go read it at “/home/osmc/.emulationstation/es_systems.cfg”!
lvl0: Error while parsing systems configuration file!

However, I do see es_systems.cfg…

osmc@osmc:~$ cd .emulationstation
osmc@osmc:~/.emulationstation$ dir
downloaded_images es_input.cfg es_log.txt es_systems.cfg gamelists

Now I’m at a loss. I just went back into the setup via SSH to install all of the core packages. Maybe that’ll do the trick…

Run the installer again.
Exactly as described in the first post of the retrosmc thread.
Without sudo!

This should take quite a while. And of course you need to be online.

Did the retropie installation run through all the way after you selected quick install from the retropie-setup menu?

Ok, after I installed the core packages via SSH, I got this new error when I ran emulationstaiton via SSH:

lvl0: No systems found! Does at least one system have a game present? (check t hat extensions match!)
(Also, make sure you’ve updated your es_systems.cfg for XML!)

So I decided to back into RetroPie Setup and install everything under the main packages area. Unfortuantely I got the above message again when I tried to run emulationstation via SSH.

I then figured, well if the tutorial didn’t install emulationstation, maybe it didn’t give me a default es_systems.cfg file. I grabbed it on my PC and opened it…blank except for the commented out example!

I redid the file and overwrite it on my Pi via FTP. STILL the same message of no system found!!!

This is an example path in the new es_systems.cfg from .emulationstation folder


This is the path I see in Filezilla:


So I have NO IDEA now why this is not working now. Anyone have any ideas?

Everything went fine last night. No errors and it said it completed. However, I will naturally take your advice and run the installer again. I will do it based on this link:

Ok, I followed everything in the Installation section here:

When I shutdown the mediacenter via SSH and run emulationstation, I still get the same error of it not being able to find any systems.

Not sure what to do now.

It sounds like a path problem, but when I look at es_system.cfg that I found in .emulationstation folder, it was still the one I created and the path matches where I put the roms. My above post w/ the cfg’s path and the real path is still accurate.

So since they match, I’m at a loss

Wait…damnit, I used the wrong link. You meant this one right?

This is what I get for forcing myself to continue past exhaustion. Once my brain works again I will try that. Hopefully it should work cause some of that I never saw on my first 2 go rounds.

Do not use the old installer.
It says so in the first post.
Now this might have messed up your system :frowning:

Damn, missed that completely. However I’m looking forward to trying again now! I have Two 64GB cards, one is a backup of my pure OSMC build. So while OSMC still works on the one I’m messing with, I’ll just re-image the card to a pure OSMC state, then try again w/ the correct instructions.

Just curious while I’m here. I’m planning on using vintage style USB controllers to play the various games. One’s an actual NES gamepad converted to USB. My SNES is original and going through a SuperJoy. Anyway, should those work through a USB hub (my Pi3 has only 1 port left) plug-n-play w/ just initial EmulationStation configuring needed?

Will post again w/ my progress for any who could use it in the future.

Depends on what kind of gamepad that is. If it shows itself to linux as a normal joystick, everything is fine.
I have some of these retro usb pads myself and they work great.

Ok, everything in that link did not match up with what I experienced.

  • I chose “Quick Install” inside the RetroPie-Setup script
  • I did not see a screen called “Choose an option” w/ “Binary-based installation”, etc… as options. The install simply finished.
  • I also did not see any windows mentioning DATA or BIOS.
  • After it finished and I exited, I went back and installed the Launcher Add-On

At this point I decided to FileZilla in to see if I had an “es_systems.cfg” file, since I didn’t get one before. No, I do not have that file in this location when I clicked “./emulationstation” in Filezilla:


I do see that I have rom subfolders here:


I’m stopping here for advice as to what to do next since everything didn’t match that page 100%.

  • Do I just copy over a basic es_systems.cfg to go w/ my es_inputs.cfg file that’s already there?
  • Do I just populate those rom folders and that’s it?

I really appreciate all of the help so far.

It is outdated as the retropie-setup script changed with version 4.
I need to find some time to change the instructionsaccordingly but I won’t be home before thursday.

If the quick install finished everything should be allright. Just run emulationstation from ssh after stopping kodi as adviced before.

The es_systems file should be created at first startup.

Let me know if there are errors.

Nope, when I stopped mediacenter and ran emulationstation, it didn’t create es_systems.cfg. It was looking for it though and told me I had no systems installed. I checked via FTP and it was not there.

I took the one i created previously from what I found online and got the same error as last time. However, where I got it from said the tilde “~” stood for “home”…but I decided to delete and just type “/home/” into the path instead.


I configured my NES USB gamepad and now I’m in the lengthy process of scraping all of the systems I copied roms into. That should take a while.

One issue I still need to test when the scraping is done, is the overscan. Right away it went off my TV. I was testing w/ NES and that command line ended in “-4” which is 720p, so I changed it (and all other 4’s) to “-5” for 1080p.

We’ll see how that goes.

Just to clearify, “~” means home directory of current user. If you are logged in as osmc “~” would translate to “/home/osmc”.

Spent some hours setting it up with copying roms and scraping…still 2 major issues:

  1. Nothing Plays - Everything has the right extension and the scraper saw it all, but regardless of the system, when I hit “A” to launch a game, it zooms into the boxart (I’m on NBBA theme), goes black for 5 seconds or so, then comes right back to whatever game select screen I was on in EmulationStation

  2. Overscan - EmulationStation is stretched past the borders of my TV. If I set overscan_left/right/top/bottom values to say “15” in boot/config.txt, that fixes it somewhat. However, it pulls in OSMC so now my mediacenter experience is screwed.

I still think something went wrong during installation.
Did you use a new system now or are you still trying to revive the old one?
Also: The first thing I would do is to try if everthing works before scraping stuff for hours…

Edit: Could it be that you are logged in as root or used sudo su?
Please do the installation and any configuration as user osmc! Everything else might lead to the problems you experience. Would also explain why ~ doesn’t lead you to osmc’s home.

Add a quick check for uid in your script and bail if you’re not OSMC