Rii mini i8+ left & right mouse click

I’ve been running an RPi 2 for some months now & before that an earlier Rpi B so I am fairly familiar with the devices…(Always ready to learn more though.) I’m running the latest OSMC + Kodi.

Anyway, I have purchased an Rii mini i8+ to control the system for it’s convenient size however I’ve struck
a problem.

The left & right mouse click on the Rii don’t work with OSMC/Kodi. Note…the Rii works correctly when connected
to a Win 10 laptop.

If in Kodi, I select Video --> Files --> Filename using a mouse right click, I get a drop down menu…using
the Rii right click , I get nothing. Like wise for left click operations…ie I don’t get what a mouse will do
with the same click

Has anyone else struck this? Is there a fix?


I’ve looked into this further & it seems a driver is either not present ot not loading or is not correctly

I’m not sure where to turn now as everything else on the Rii, that I’ve tried, works.

I’ll keep on looking…

I’m not sure how to add info from my RPi2 so apologies if below is out of order.

Here is the output from lsusb…the Rii is 1997:2433

osmc@osmc:~$ lsusb
Bus 001 Device 008: ID 1058:0748 Western Digital Technologies, Inc. My Passport 1TB USB 3.0
Bus 001 Device 007: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
Bus 001 Device 006: ID 2109:0811
Bus 001 Device 005: ID 046d:c52e Logitech, Inc.
Bus 001 Device 009: ID 1997:2433
Bus 001 Device 004: ID 7392:a812 Edimax Technology Co., Ltd
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Here is output from dmesg when loading the device…
[ 308.978213] EXT4-fs (sda1): last error at time 1420948995: htree_dirblock_to_tree:920: inode 66322697: block 265297965
[ 1540.633728] usb 1-1.3: new full-speed USB device number 9 using dwc_otg
[ 1540.742486] usb 1-1.3: New USB device found, idVendor=1997, idProduct=2433
[ 1540.742522] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1540.742540] usb 1-1.3: Product: Mini Keyboard
[ 1540.742556] usb 1-1.3: Manufacturer:
[ 1540.757015] input: Mini Keyboard as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.0/0003:1997:2433.0003/input/input4
[ 1540.815931] hid-generic 0003:1997:2433.0003: input,hidraw2: USB HID v1.01 Keyboard [ Mini Keyboard] on usb-3f980000.usb-1.3/input0
[ 1540.826146] input: Mini Keyboard as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.1/0003:1997:2433.0004/input/input5
[ 1540.884828] hid-generic 0003:1997:2433.0004: input,hidraw3: USB HID v1.01 Mouse [ Mini Keyboard] on usb-3f980000.usb-1.3/input1

So , it’s being seen as a keyboard / mouse which is correct & the keyboard, as such, works ok, so
the questiion is per my original post…why doesn’t this work with mouse clicks?


I have a slightly different Rii remote (New USB device found, idVendor=1997, idProduct=1221) but that also has mouse function and as far as I remember that is working.
So you are saying your mouse pointer is working but if you go above a menu item with the mouse pointer pressing left/right mouse button doesn’t have a function?

Also just as a side note I believe you are much faster with the keyboard than the mouse as Kodi was designed from remote control. Just press ‘C’ to get the context menu and the cursor keys to move around.

i have the exact keyboard for 3 or 4 months now and appart that the build quility is below average (basically most of the keys are starting to wear off/ loose the black color), the keyboard works fine and the mouse keys are working.

Try using the keyboard into a computer and be sure that the mouse keys are working. I have no problem here.

That’s exactly what I was saying, however, the wording of your question gave me cause to re-think the problem
and try something and BINGO it works.

It seems the cursor/app positioning with keyboard & mouse are mutually exclusive.

I was using the keyboard to select different the options and then the mouse., where I really needed to use the
track pad to position the cursor on the option & then right click…works fine then…:laughing:

Honestly, if I can figure out how to do this via my TV remote ( CEC ) , I’d use it for convenience but it
presents a simiar problem as the k’bd/mouse brings. ie how do I move the cursor with CEC & which key/s
on the remote transmit left & right click?

Perhaps the real answer lies in tweaking Kodi to recognise left/right keyboard clicks as mouse clicks. That
would probably translate to both a keyboard & TV remote.

I’ll look at this as soon as my grandson gives me the TV back…

Thanks for your reply…please re-read my original post.

Thanks to both of you for input…much appreciated.

The CEC problem aside, I’ll mark this as “solved”.


That’s it…!!! I’ve got the TV back for a few minutes & tried this…you’re spot on…much quicker…great stuff.
Always wondered about the reference to a “context menu” but didn’t pursue it.
Now…how do we do this via CEC???


It’s quite important to be aware of the keyboard controls in Kodi at times :wink:


Depends on which keys of your CEC remote are working. E.g. I have one TV remote that has a “info” button that is paththru to Kodi and works for context. But I have another TV on which I even don’t get left/right passthru correctly.
So you need to check which keys on your TV remote are given to Kodi and if no context key is part of that you may need to remap.

I am not sure if you have read my previous comment. Kodi is not designed to be used with a mouse. Technically there are no left/right click in Kodi.
This would be the select and context actions instead.

On my LG TV I have to quickly press stop and start after another to bring up the context menu via cec.

Interisting, will try that.
Anyhow generally I use my Rii remote.

Yep…read it…didn’t absorb it…( hard to avoid but don’t get old :cry: )

I’ll try some of the other stuff mentioned but I, like you, am now pretty comfortable with the Rii now
that I know the ins-and-outs.Once again…thank you.

If I’m not on the boards again in the next few weeks…have a good Christmas.