Root cant be enabled

Hi all
I tried to enable the root user by:
sudo passwd root
It look like it enabled the user but when I try to access it using root/pass It just fail
That way I cant edit my nginxs files (in /etc/nginx/sites-available)

You can use sudo -s to temporarily gain root access without enabling the root account.

You need to change sshd_config if you would like to allow root login. Look for PermitRootLogin no and change to yes and run sudo systemctl restart ssh. But I do not recommend this as it’s not needed for what you are trying to achieve.

1 Like

I don’t have any knowledge about linux… Then its too hard to manage my files without being the root
I appreciate the help! it works like a charm

What is hard about typing ‘sudo -s’ after logging in to change to root ?

because I use ftp to edit the files
And using sudo -s over ssh i could not see some files using nano :hushed:

If you are using something like WinSCP, you can still do this with sudo. There is an option for it, but I forget what it is.

Then I would strongly recommend not galavanting as the root user.

Sam

This is where you change the Shell in WinSCP;
https://winscp.net/eng/docs/ui_login_scp

By using the ‘sudo -s’ argument like Sam suggested should let you have full read/write access to all of your files in a nice graphical view without needing to install any additional tools/services on the OSMC system

1 Like