RP2, july update osmc, not playing m4v files from usb drive, nor files from "iplayer"

Running OSMC on Raspberry. Updated to latest OSMC. I have files on a powered, usb-drive. When I try to play the files (which I made with handbrake myself from DVD’s) they do not play anymore. OSMC gets stuck at the “wait-for-it” symbol which will keep on showing without anything else happening. These files used to play well, without a problem, before.

I share the libraries in which these files reside through UPNP. And I can play the self same files over the network on a Vero4k without problems.

I’ve put up logs here: https://paste.osmc.tv/ujugucewag (this was after waiting for 5 minutes for a file to be opened, which it never did).

The only way I found as a way out of this situation is to reboot the system through:

sudo systemctl stop/start mediacenter

Additionally: playing files from the Dutch iplayer does not work either anymore at the moment. Same symptoms: after selecting a file the “wait-for-it” symbol, but nothing else. Only way out also: sudo systemctl stop/start mediacenter.
The logs for this situation can be found here: https://paste.osmc.tv/ojequtizaz

Music files on the same usb-drive do play on the Pi.

Any advice?
If there is any more information I can provide, please let me know.
Thank you.

Whats the mediainfo from the file?
Please see the mediainfo section in How to submit a useful support request - General - OSMC.

You can also create the mediainfo-output of the affected media file on the OSMC device:

  1. login via SSH, user osmc, password osmc
  2. if not already installed: sudo apt-get update && sudo apt-get install mediainfo
  3. cdto the directory containing the video/audio material in question
  4. mediainfo -f "<media file>"|paste-log, where <media file> is your video/audio
  5. publish the returned URL here in this topic

Thx for your help.

====================== Pi config =================== Ul2H1CLu

---------------------- Pi config END --------------- Ul2H1CLu

It looks like you are under clocking your Pi3!

Then that is something I have not knowingly done. Wouldn’t know how. :frowning:
If it’s unrelated to the problem above I suggest to leave this for now, unless you think under clocking is the cause of the problem.

In MyOSMC piconfig, revert from turbo to normal. Confirm and reboot. Test your file again and provide new logs if issues persist.

Thanks. Will do and report back shortly.

@ActionA Did as you suggested, the pi is now running “normal”.
No change in behaviour though.

After trying to open the same file, I did grab-logs -A: https://paste.osmc.tv/kumizeciwo

Then I installed and ran mediainfo: https://paste.osmc.tv/ojuyuzoyib

Is this useful?
Anything else I can do/try/report?

Looks better. But just for the record you have a Pi 2 not Pi 3 as written in the title

:thinking: I do have a pi3 somewhere, I’m sure…

Changed title to Rp2. Thanks

I tried something rigorous, in the hope that it would solve things: I removed the oscm-user folder to “reset” the system.

This did not solve the problem however.

Any ideas what to do next? Any information I can provide?


Just a ‘hunch’, but if you installed OSMC with (an older) NOOBS i’d guess it created a config.txt for Pi1 regardless of what Pi you have. However I don’t know if you used NOOBS.

I’m fairly certain that this doesn’t happen. Noobs are very attentive to the different iterations.

@El_Grincho, thanks for the suggestion. Not sure whether I used NOOBS for this one. But I think I tend to agree with @ActionA’s assumption. Also: this setup has been playing these files without problems before. I think that rules out Noobs as a source?

Anything else I can investigate?

I might try a complete reimage.

@ActionA, :frowning: well, it might come to that - there’s nothing in the logs I provided which seems to suggest a different solution?

The problem and the weird clock-speeds in config.txt are two separate things - so, both yes and no?

@El_Grincho Thanks. I adjusted the clock-speed before uploading the last logs; I hoped that this would clear the logs up enough to see what’s going on. But if there is nothing in there, I’ll have to do a clean install.

I already tried to install osmc on a fresh sd card - could not get osmc-install to work on a xubuntu 18.04 machine though. So, I can’t yet report if a new install solves the problem.

Not sure what I can do now. I’ll have to have a think for a bit.

I’m on Mint 18.3, and i just right click the image and write to a SD-card. I have never bothered with the OSMC installer.


There was an issue with ubuntu 17.10 that may have sneaked into 18.04, where it installs but doesn’t get added to to the apps menu.

you can still run from the command line, if that isn’t is the case and it hasn’t installed; you could try installing manually from the command line. Details can be found here:

Thanks Tom.