RP3 + OSMC -powering on when TV is off - no signal

I’m using OSMC for few years on RP3 B (standard non-B+ version)
Few months ago at the same time (I know - my mistake, I should have done that one by one to know what caused the problem) I’ve changed TV to Phillips 55PUS6754 and installed clean version of OSMC (old one was messy, too many addons, too many additionally installed packages which no longer were used, etc)
Now everything works fine EXCEPT … powering on OSMC. When my TV is OFF and I power off RP3 -> system starts (I have access via ssh, all services seems to be up) but when I turn on my TV it says that there is no signal over HDMI (I’ve tried 3 different cables, PS4 PRO works fine on those cables), I’ve tried using different HDMI powers on TV.
But if I power on RP3 when TV is ON - everything works fine (and after that I can turn on/off tv and everything works great).
What can I do to help you identify problem with my setup ? I’m using most recent version of OSMC (I was upgrading all packages often hopping that this will solve issue, but nothing helped). It’s not deal breaker for me (how often you power off RP3 ?) but it’s annoying.


You might try editing your config.txt to force the display output mode. Most likely this would be CEA mode 16 which gives 1080p @60hz.

I;ve added:
and it looks like it’s working with one exception - it looks like this disables “hdmi_ignore_cec_init=1” option (and now when RP3 is restarted TV is auto-turning on)

You can disable that under settings - system - Input - Peripherals