Rpb4 - Always sad face when starting some TV fictions or films in some addons

on my Raspberry PI4with the latest Kodi version i always get the bad face when i try to start some TV films or fictions in some addons (such as Netflix, Amazon, ecc…).
These are the full debug logs:


Can you help me undestanding why this happen?
Thank you in advance

Does this only occur with Inputstream Helper add-ons?


@sam_nazarko Hi Sam,
probably i solved the problem!
Yesterday i downloaded the OSMC image for Raspberry Pi4 (the June version) and i thought that was the latest version with the latest components versions; after the addons setup i reproduced the problem and i opened the topic on the forum.
Some hours later, i tried to start the OSMC update from the OSMC settings (without particoular reasons, i thought i was on the latest version) and it started to download some packages and then it installed them; after this process, i didn’t reproduced the problem again.
Maybe it was a bug that it was solved…
I don’t know why this updates were not in the latest version of OSMC for PI4 that i downloaded yesterday morning…but as they say: all’s well that ends well!