RPi 2 + Aplha 4 - No display on startup

I’ve used the new OSMC installer to create a micro sd card for RPi 2.

It seems to boot fine, command lines run up, I get to a screen when it says someting about the 4 processors and then it ends. Screen flashes, TV says no input signal…

I can SSH to the Pi2 so it works.

I’ve tried HDMI_SAFE=1 in config.txt, but did not help.

Any idea anyone?

Try this


It seems the current video mode should be supported:

osmc@osmc:~$ /opt/vc/bin/tvservice -s
state 0x12001a [HDMI DMT (36) RGB full 5:4], 1280x1024 @ 75.00Hz, progressive

osmc@osmc:~$ /opt/vc/bin/tvservice -m CEA
Group CEA has 16 modes:
           mode 1: 640x480 @ 60Hz 4:3, clock:25MHz progressive
           mode 2: 720x480 @ 60Hz 4:3, clock:27MHz progressive
           mode 3: 720x480 @ 60Hz 16:9, clock:27MHz progressive
           mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz progressive
  (prefer) mode 5: 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced
           mode 6: 720x480 @ 60Hz 4:3, clock:27MHz x2 interlaced
           mode 7: 720x480 @ 60Hz 16:9, clock:27MHz x2 interlaced
           mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive
           mode 17: 720x576 @ 50Hz 4:3, clock:27MHz progressive
           mode 18: 720x576 @ 50Hz 16:9, clock:27MHz progressive
           mode 19: 1280x720 @ 50Hz 16:9, clock:74MHz progressive
           mode 20: 1920x1080 @ 50Hz 16:9, clock:74MHz interlaced
           mode 21: 720x576 @ 50Hz 4:3, clock:27MHz x2 interlaced
           mode 22: 720x576 @ 50Hz 16:9, clock:27MHz x2 interlaced
           mode 31: 1920x1080 @ 50Hz 16:9, clock:148MHz progressive
           mode 32: 1920x1080 @ 24Hz 16:9, clock:74MHz progressive

osmc@osmc:~$ /opt/vc/bin/tvservice -m DMT
Group DMT has 13 modes:
           mode 4: 640x480 @ 60Hz 4:3, clock:25MHz progressive
           mode 5: 640x480 @ 72Hz 4:3, clock:31MHz progressive
           mode 6: 640x480 @ 75Hz 4:3, clock:31MHz progressive
           mode 8: 800x600 @ 56Hz 4:3, clock:36MHz progressive
           mode 9: 800x600 @ 60Hz 4:3, clock:40MHz progressive
           mode 10: 800x600 @ 72Hz 4:3, clock:50MHz progressive
           mode 11: 800x600 @ 75Hz 4:3, clock:49MHz progressive
           mode 16: 1024x768 @ 60Hz 4:3, clock:65MHz progressive
           mode 17: 1024x768 @ 70Hz 4:3, clock:75MHz progressive
           mode 18: 1024x768 @ 75Hz 4:3, clock:78MHz progressive
           mode 30: 1280x800 @ 85Hz 16:10, clock:122MHz progressive
           mode 36: 1280x1024 @ 75Hz 5:4, clock:135MHz progressive
           mode 82: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive

Is there a way to change video mode via ssh?

CEA mode 5 is preferred. So you need to edit /boot/config.txt and add

hdmi_group=1 hdmi_mode=5

and then reboot.

I’m hoping you had previously already removed the safe mode line right?

Unfortunately no luck.
I’ve tried many different hdmi_mode -s. It does not matter what I set it just goes black after showing cpu info.

This is my config.txt:




Screen is still black.

Checking the resolution from SSH shows the 1280x1024 value again:

osmc@osmc:/boot$ /opt/vc/bin/tvservice -s
state 0x12001a [HDMI DMT (36) RGB full 5:4], 1280x1024 @ 75.00Hz, progressive

Just for confirmation, I’ve tried it from Openelec and there is no problem with that.
Also, raspbmc was working on this tv with Pi 1.

Why do you have the clock speeds and gpu_mem commented out? Is that your complete config.txt?

I’ve tried with and without those lines as well. I was trying to match the config.txt from openelec install.

This is what they have and works:




Hold on, the 4th reinstall seems to solve the problem.

Most likely the SD card is marginal or it isn’t making good electrical contact with either the slot in the Pi or the slot in your SD card writer.

There’s nothing software related that would cause the install to fail 3 times and work on the fourth…

Thanks for your help!

Just to make the story complete, I’ve used SDformatter to format the SD card before the 4th install, which worked.
Probably there was an error on the sd card OSMC installer could not fix.

Hi there,

I have an issue which sounds somehow similar with this title…
my always on rpi 2 running alpha 4 is working fine unless, I do a reboot while my tv is off, then I get no signal when I turn on my tv.
To fix it at the moment I just do a reboot with the tv on, then all is fine.

Is this feature or bug?
I mean is by purpose to not start kodi when the tv is off?

This is a common issue because the Pi needs to read the EDID data from the TV at boot time, but some TV’s don’t provide this information if the TV is in standby while some do. The solution is to save and enable use of an edid.dat file:


The OSMC addon Pi settings module provides a way to automate this.

Many thanks for this hint, I managed to create this edid.dat file and now the issue is gone…

@DBMandrake, what option in the Pi Config menu does this? I’d rather use the “official” method if i can.

update: i used “store_hdmi_to_file” and it created the edid.dat file, then i used “hdmi_ignore_edid” expecting it to update the config.txt file, but it did not do so.


You need to be using hdmi_edid_file=1 and hdmi_force_hotplug=1

@ActionA yes, that was what i was expecting to be added to the config.txt file automatically when using the Pi Config GUI menu option hdmi_ignore_edid. However, i had to manually add them (so far, i can’t tell what the hdmi_ignore_edid option does). All is working as exptected (after manually adding the config lines to the config.txt file), but i wanted to know what @DBMandrake meant by “automated”… having to manually edit the config.txt file to add these two configuration options doesn’t seem automated. I’m thinking i’m doing something wrong, but don’t know what. Also, these configuration options don’t exist in the Pi Config menu options (that is, there is no hdmi_edid_file or hdmi_force_hotplug options on the Pi Config menu).

All is working fine, i just wanted to clarify, possibly helping someone else get to the fix faster with less ambiguity.

Thanks guys for all you do for the OSMC community! :slightly_smiling: