Rpi 2 doesnt get detected by new tv

hello, i just got myself a new samsung KS8500 today and i’m already pissed at it since it doesnt recognize the rpi2. My rpi2 is connected through the hdmi matrix then to the one connect box (samsung is using a small box to have all hdmi ports to slim down the tvs) all i can see is ablack screen i know the rpi is on i can ssh but nothing shows up on my tv no matter what source i select. please advise

  1. What does tvservice -s show when you type it in ssh ?
  2. Try adding:
    to your config.txt, reboot and see if it worked.

state 0x12000a [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 60.00Hz, progressive

already had hdmi force hotplug

seems to be some hdmi setting thats acting up if i set hmdi_safe=1 i can see osmc but in very low res and every click on tthe remote makes the screen goes dark then comes back

Could also be a problem with the hdmi port or cable. Maybe you damaged it while connecting the new tv?

Try the following

already tried that still not working

The only time i had a black screen on my TV was when i was playing with the resolution on the pi. I had to connect via VNC from my pc to see the interface and lower the video resolution again.
You could try 3 things to see if its a resolution problem.

  1. Lower your TVs resolution and reboot the pi…see if it’s working on lower resolution.
  2. In your config.txt set:


Its a 720p resolution but its just a temp thing to see if it works.

  1. If the above doesnt work…remove those lines and just add hdmi_safe=1 , and see if it works.

By the way…do you at least see the logo when the pi boots up ? Or its totally black from the beginning.

Tried a different cable/hdmi port?

ok tried a different port and it worked howver i can’t control the rpi with the new remote control…this is just annoying

Did you enable CEC in System settings ?

Don’t you mean “in the TV’s System settings?” Because CEC is always enabled by default in OSMC.

hmmm mine was off … but i remember i also had an outdated libCEC driver. We did something with Sam to update it to ver3…maybe i was the unlucky one.

yup correct everything is enabled on osmc and on the tv, i’m thinking the new samsung tvs are dealing differently with the cec (anynet) features

Turn everything off. Start the TV and allow it to fully boot and set it to the appropriate input for the Pi. Then boot the pi and see what happens.

And try a different cable!

Some of the latest Samsung TVs do not have anynet+ (CEC) installed.
So if this is the case in your TV then that is the root of the problem. Nothing to do with OSMC.
I had this issue myself, assuming that all Samsungs have the facility.