RPi 2 missing device node loop

Hi all.

Got my RPi 2 today… I have downloaded the windows installer and told it to install to my sd card which is a 1gb kingston I think… I have inserted the hdmi, ethernet, mouse, keyboard and a 8gb usb flash pen.

On power up I get the coloured screen and then a black one with the following errors;

missing device node for cpu 0
missing device node for cpu 1
missing device node for cpu 2
missing device node for cpu 3

etc… this just then restarts and loops…

Where am I going wrong and what am I missing?


Try without usb pen

Tried that… also downloaded NOOBS from the Pi site, and copied onto an 8gb sd card that I had lieing around… then i just get the coloured screen flashing at me…Cant be a faulty Pi board as i bought 2 and both do the same thing.

Try without anything. Only TV and Ethernet

Also if it doesn’t work, try downloading image http://download.osmc.tv/installers/diskimages/OSMC_TGT_rbp2_20150202.img.gz, unzip it and flash it directly to SD card.

I did that few days ago - worked perfectly.

Just done that also… I will give the image a try and post up

Also make sure you use decent power supply, maybe try to use different one

Still nothing with the image… getting same cpu node errors

power supply i am using was an apple charger giving 5v and 1a, tried it on a pc usb port which give 5a i believe and same problem occurs,

1a is to weak, it should be stable 2A power supply. PC usb is not suitable too, however it should work.

Don’t mind cpu node errors. There are standard and will be hidden in next release I believe. There is something going on except it that is causing the loop/restart/freeze.

Are you sue you are using image for RPi2 not RPi 1?

Also you can mount/open your SD card on PC and modify cmdline.txt (its on the first partition). Remove the “quiet” word from it and save the file, unmount gracefully. Then try again to boot your RPi2. The output should be more verbose.

[EDIT: There is always possibility of broken SD card. Please try to use another one. ]

Get yourself a decent 5v 2amp supply designed specifically for the Pi 2 - they’re even more fussy about power than the previous model Pi’s.

Forget about trying to run it from an Apple charger, or from a PC USB port - neither will work.

Ok thanks guys… I have ordered a pair of 5v 2a ac’s off ebay… i will let you know how i get on.

Also i am using a fresh image not the image from the rpi 1.

its now working with the 2a psu i ordered :slight_smile: thanks for the help

I have the same message. I’ve been using the same setup for ages. I put it away because business for work. then today I reboot, except I can’t. It just gives this error and loop. Tried with nothing attached. Tried different memory. and different and known reliable 2a supply. Nothing had changed except for not being used and a different monitor. Both monitors use the same cable and connector types etc. No visual issue.

Well you are replying to a post from 1 year ago. Sorry to tell you but the earth have move since then and as well has OSMC:
Since June 2015 OSMC move from beta to stable. As no update path is available from Alpha releases I suggest you to a fresh install and report with a new thread if you have any problem.

So what 1 year. I have the error and the PSU is the original… Problem exists. If you can’t help just shut the hell up instead of moaning that someone else on this planet has the same issue. I’m looking into replacing the perfectly OK PSU. I know because I tested it with MultiMeter and it’s stable and sure as hell meets the requirements and was working the last time I used it which was with this very device and setup… Your response was unhelpful… No offence, not personal, but I’m sick to death of people assuming because an issue is solved for one person others can tell me I’m an idiot for reporting the same issue which was not solved by the advice that helped others. this in itself can help yet someone else who reads this thread. I have as much right to mention my issue as anyone else no matter how old the device is.

Where the hell do you get off acting like a complete douchbag ? Seriously ?

You are the one that is assuming that the problem is the same as the original poster.

fzinken didn’t tell you to try a new power supply, he suggested you do a fresh install. So have you tried a fresh install ?

You don’t have any right to act like a twat on a public forum though. Keep it up and you’ll be banned.

I’m sick of people who do not update to the latest stable release and not testing for a couple of days before splurging on a forum.

Ok so you can’t help me. You didn’t have to say anything. you don’t know what I have and hadn’t done beyond what I have said. You do not know what versions are running. You assume something says stable it’s actually stable… nothing could possibly go wrong so I’ll just assume the person complaining of an issue is wrong instead of helping. This place is clearly not a place to look for help. I wont be back… I’ll be deleting my account thanks. Bullshit artist!

Because you have failed to provide any information.

Nobody in the software world is going to spend lots of time debugging problems in an extremely old release of software - it’s a complete waste of time because the issue you have may be fixed long ago.

Unfortunately because you can’t be bothered to even tell us what version of OSMC you are running and don’t seem to be willing to update to the latest version and re-test, nobody knows…

Don’t let the door slam on your arse on the way out…