RPi 3 and HifiBerry Digi+ - White Noise

Just got my Pi 3, and setup a new Micro SD card from scratch. Initial thoughts are that its alot faster than my RPi 2.

I have also got the HifiBerry Digi+ (SPDIF Out) and after turning off LIRC Support, When I select ALSA Default (snd_rpi_hifiberry_digi S/DIF) Instead of HDMI audio out, all I get is white noise.

I am running the very latest OSMC (February 2016 2016.02.3), but still this persists. I have also tried re-seating both ends of the Optical Lead.

This problem doesn’t exist on my RPi 2 with the same setup.

Any help would be appreciated.


Does adding “core_freq=250” to config.txt make a difference?

Seems to have sorted it for the moment. Though after the reboot after changing the config.txt there has been a few occasions when clicking through the menu.

Ill post back if it re-occurs.


Its come back again. Do you want a copy of the log?

You can post the log just to confirm the core_freq=250 is present, but if it’s not that then I don’t know if the log will help.
Might be worth keeping an eye on this: https://github.com/raspberrypi/linux/issues/1321
which is probably the same issue.

Found a (temporary?) solution on the hifiberry forum:
Add dtoverlay=pi3-disable-bt to the /boot/config.txt before dtoverlay=hifiberry-digi-overlay

dtoverlay=pi3-disable-bt dtoverlay=hifiberry-digi-overlay

Then (ssh connection needed!)
sudo -i cd /boot/overlays/ wget https://raw.githubusercontent.com/raspberrypi/firmware/master/boot/overlays/pi3-disable-bt-overlay.dtb

Reboot and enjoy - at least I am!

1 Like

This has been fixed in the Pi kernel tree. See here.

Hopefully Sam will pick that up in next update. The dtoverlay workaround you are using is fine for now.

It will be in the next update


I can confirm that this seems to work also for the Hifiberry Dac+ Pro on Raspberry Pi 3 (had the same issue there).

short question: With the april update has this issue been fixed?
If yes, then the dtoverlay=pi3-disable-bt command can be moved if I am not mistaken.
Thank you for a quick feedback.

Yes – you no longer need that DT overlay

Thank you very much Sam :slight_smile: