RPi 3 Black Screen After Splash

After either installing the latest version of OSMC, or after installing the second latest version and updating, the screen goes black after the splash screen. The Pi is connected via HDMI, and I know Kodi is loaded because the sound is coming through. On the direct installation, the installation progress bars worked fine, then gave the black screen after restarting. What should I do?

Log in via ssh and provide logs via grab-logs -A

It working with the previous version may have been a fluke, as I could not replicate. I did get the display to work on the previous version by unplugging and replugging the HDMI cable. I’ll try the update (and get logs) when I get home again.

Here are the logs:
I’ve rebooted once now, and had to unplug and replug the HDMI cable to get the display to display. The log I gave is pre-update. I’m going to do the update now and post those logs as well.

Logs directly after update, while screen is still black: http://paste.osmc.io/ezidicoxek
Unplugging the HDMI cable worked again. How can I get HDMI video to properly auto-detect after restart?