RPI 3, External USB and SMB ...Fail!

Hello All
yes its my first post
and trust me i have read a lot on my issue
and tried a lot and just end up reinstalling on the SD card after bricking it
by messing with various conf files …

So how did i get here …

Well …i have used Open**C for around as year on my RPI2 and was fairly happy …no issues …
I basically have the RPI attached to a USB drive …and when i get a movie …I copy it over the network from my windows PC to that USB and play it locally on my Kodi

But when i got excited with my new RPI3 …i realised it did not get on with Openelec or Krypton in some ways…so i took advice and flashed my SDCard with OSMC …

I was impressed …Its clean and easy !!!

BUT …i noticed from my windows Pc all i could see was Files, Videos, Pictures and Music Folders,
but what i REALLY need to see is the USB drive …which i confirm is at /sda1

Now I have installed Samba server on my OSMC …but cannot see a way of actually configuring shares within it

But i have changed all permissions to 777 (i know noobish)
I have tried to unmount and mount on /usb/media

everytime i edit my conf files the OSMC wont boot
and as i cant edit the linux system files i have to reload the img !!!

the error is usually something like cant mount /sda1 …blah blah
timeout …blah
and back to

can it be THIS HARD to share the external usb drive with windows ??
i never thought about it in openelec …it was just THERE

If you install the Samba server, attached media is shared automatically.

You don’t need to edit any files.

Where do you see these? Can you screenshot your Windows Explorer screen? You should see something like this:

osmc is the ‘home’ folder and on my device verodev and veroboot are attached drives, automatically shared by SMB.

Well, i sorted it eventually …by doing a little research and i feel a bit stupid LOL.
I even asked some buddies who were a lot more clued up …but they suggested all sorts of elaborate Linux fixes …but it was un-necessary

If anyone else has my problem …here is ALL that you need to do

  1. On your OSMC you need to install the SMB “SERVER” from the (App Store) Shop Cart, Icon within OSMC.

  2. Reboot OSMC

  3. Make sure that you have enable SMB client options (especially SMB1 in your Windows PC via the “turn windows features on or off” dialogue

  4. Reboot PC

  5. Once PC has restarted type CMD (run as administrator) and then type this in dos screen (without quotes)
    “net view \192.168.xxx.xxx”
    …replace the IP with the one of your OMC/Kodi/RPI

  6. It should give you a list of shares on that Box (if it doesn’t check all the steps above again

  7. now here is the bit i SHOULD have worked out earlier (*doh)
    Once you know your share name for example say your external drive is called “Seagate”
    to access ALL its files in windows all you need to do is the following:

Open up “This PC” or File manager and enter the following DIRECTLY INTO THE BAR AT THE TOP.
\192.168.XXX.XXX\Seagate …do NOT enter this into the explorer or google bar, and do NOT attempt to Map Network drive or add a network location …its a lot EASIER than that :slight_smile:

It will then appear in Network locations and you can make a shortcut or do what you like …treat it as a normal network drive …cos it is !

For PC heads like me …if you get problems its more than likely because we dont understand how “fussy” linux is …make sure you Check the names match exactly in the right case …and make sure you know your //'s from your \'s

Smart people will find this post pointless …I am sure …but its for us noobs (shhh)

You may want to correct that, it the App Store in MyOSMC and not Addons.

Glad you got it sorted. Once you have installed the SMB server, the shares should just appear as I showed above. The only wrinkle I have found is when Windows thinks it’s connected to a ‘public’ network. If you set your network to ‘private’ those shares should be there without restorting to a CMD.