Rpi 4 architecture armhf instead of arm64

I did a fresh install of OSMC with 2021-08.1 on raspberry pi 4.
I had some issues installing docker containers becouase the dpkg achitecture says its armhf instead of arm64/aarch64.

Changing the repo an install for docker in apt fixed. But would be nice to have this correct by default


osmc@osmcumbrel:~$ dpkg --print-architecture

The Pi 4 OSMC image is multi-architecture, like the Vero4K/+: user space is armhf and the kernel is arm64/aarch64.

dpkg runs in user space as a 32-bit armhf binary and, AFAIK, the architecture is built-in to the installed package. So the “foreign” architecture is arm64, as running dpkg --print-foreign-architectures will confirm.

Thabks. When i explicitly tell dpgk to install an arm64 package,bit installs as I want it.

So you’re explanation brought me to the solution.

Hi cjvanzwol, could you please share your solution?
I have issues with docker on rpi4 like no networking in ubuntu container etc.

`docker info | grep Architecture
Architecture: aarch64

docker inspect ubuntu

“Architecture”: “arm”,
“Variant”: “v7”,

I suppose it is because of architecture mismatch.

Update: I have figured it out, there is an arch definition in repo link. Now it works, thanks for the idea.

I added the arm64 repo:

deb [arch=arm64] https://download.docker.com/linux/debian buster stable

to /etc/apt/sources.list.d/docker.list

sudo apt update
sudo apt install docker

This should install docker for arm64.
maybe I added :arm64 to the command. Then it would become

sudo apt install docker:arm64

I tried a lot and I’m not sure what exactly wa the sollution. But this seemed to stick.