RPI 4 - issues with 2021.08-1 release

My apologies if this has been addressed earlier, a search did not seem to show anything related to it. I am trying to use the Pi 4 with 2GB RAM and when I try a SD card with the 2021.08-1 version, I get the error message shown in the attachment. It is complaining about the start4cd.elf. I have to stay with this version because of other issues related to playing slide shows from folders that have both pictures and videos.

Pi4 was not supported at the time of that release. Newer release will be required.


I copied some files from the latest release to the 2021.08-1 release, and that seems to have worked, I have to wait and see whether the slide show freeze problem will show up.

You need to update the EEPROM on your device I think.

Thanks, but how can that be done without the rpi-eeprom-update command? Raspberry Pi 4/400 EEPROM Firmware Update/Recovery Guide - Trying to install that did not seem to work, the package could not be located.

osmc@osmc:~/Programs$ vcgencmd bootloader_version
Apr 29 2021 17:11:25
version c2f8c388c4ee37ad709ace403467d163e8dd91ce (release)
timestamp 1619712685
update-time 1619712685
capabilities 0x0000001f

Is this an outdated version?

Is there a specific reason you chose to use the 2021.08-1 release and not the latest version?


I installed Raspbian, upgraded the EEPROM. Now I have:

osmc@osmc:~$ vcgencmd bootloader_version
2022/01/25 14:30:41
version 6efe41bd9d1e5546fa3715e72e1775b7bd813237 (release)
timestamp 1643121041
update-time 1648674384
capabilities 0x0000007f

I then tried to used the 2021.08-1 release, it gave me the same error about start4cd.elf. So I gave up, copied the non-image files from the latest release, and got it working.

The other issue I have is that the 5GHz wifi SSID does not show up with any OSMC release, only the 2.4 GHz wifi SSID. I see some hidden network with a strong signal. But no problems with regular Raspbian, both SSIDs show up and I can connect to either.

You can try with connmanctl via command line.
Otherwise my suspicion is that your 5Ghz network channel is > 100 or you need to set the CRDA world regulatory domain.

Connmanctl services also shows a hidden network after a wifi scan. wifi_e45f018f5812_hidden_managed_psk
5GHz channel is at 157, is that a problem with OSMC, but not with regular Raspbian?

You need a newer version of OSMC; or lower channel.

Old versions aren’t supported.

I can switch to a lower channel or stay with 2.4GHz, not a major problem. I don’t recall seeing the 5GHz SSID even with the latest release, but I could be wrong.

Regarding the issue of slideshows with pictures and videos crashing with the newer Kodi version, is that an OSMC fix or is that something that has to be taken up with Kodi?

It’s an upstream issue.