Rpi + LG 32LC42 HDMI no audio, jack working

After using raspbmc without problems i installed now osmc and have no audio over HDMI and simplink (CEC) is not working anymore, but this is another problem not to be discussed in this thread. Audio jack 3.5mm is working fine.

I watched the logs but did not find any audio related errors or information. Where can i start to debug this problem? I tested the Hardware, everything ok, sadly i have no other HDMI device to test with Audio, but the cable and the TV worked with another laptop.

Maybe related to: LG 32LC42 SIMPLINK HDMI CEC not working

What resolution do you have Kodi set to ? 1280x720 / 1920x1080, or something else ?

Also please upload your log files.

Thx for your reply.

In kodi System->Video “DESKOP” is set as resolution. My TV says 1360x768.

enabled debugging, rebooted pi, started video stream (video addon twitch), video via HDMI ok but no audio, analog audio works fine.

kodi.log http://paste.osmc.io/puqelopayo
dmesg http://paste.osmc.io/qesafirahe

I can’t see anything in the log files that suggest an audio problem.

Have you tried a different HDMI cable, or plugging the Pi into a different TV ?

Yes, i tried different cable and with a laptop on the same tv, no problem. i have no other HDMI TV to test this but my notebook is working fine with the TV.

Stupid question, as you write 'jack working" I assume you have switched audio from jack to HDMI when you want audio to be on HDMI

Sure, i switched it in Kodi but there is an option for “both” too, so i used it in raspbmc and it worked gladly.

I reinstalled RPI and resetted TV and now audio is working again but not CEC / SIMPLINK: LG 32LC42 SIMPLINK HDMI CEC not working
Why is audio working now? I have no clue, i installed OSMC and resetted TV before so i can’t reproduce the problem.