RPi Zero W - Screen blinks when WiFi is active

Zero W topic is closed, so I’ve created a separate one for my problem.

I have a RPi Zero W device and I installed OSMC via Windows installer (version 2017.04-1).

The problem is: when I turn on WiFi on the device from OSMC menu, connected display (TV-set via HDMI) starts to blink. Here’s a video of the described “effect”: Dropbox - cut.mp4 - Simplify your life

It looks like this issue, but I’ve tried several different USB cables and power supplies (from 2A to 2.4A) - all with the same result, so I’m not sure if it’s really power-related in my case.

If I turn WiFi down - everything performs pretty smooth, no screen blinking. But I need a network connection in order to control the device via web interface.

Does anyone else experience the same issue? I mean, RPi Zero W computing power is enough to run OSMC controlled via web-interface over WiFi, isn’t? Can anyone confirm a successful use-case?

I don’t have any non-default plugins or services installed, it’s a “clean” installation of OSMC.
The log uploaded from My OSMC menu is here: http://paste.osmc.io/ugesunojos

Looks like it maybe a power issue to me, have you tried a power supply like this:

https://osmc.tv/store/product/raspberry-pi-power-supply/

Thanks Tom.

1 Like

Do you see the same issue on a different TV?

1 Like

I’ve tried it with my PC display - works just fine, no screen-blinking.
What can be wrong with my TV-set then, why does it have such a problem? I have an off-the-shelf Set-Top Box here, and it works fine with the same TV-set.

At a guess I’d say the signal reaching the TV is marginal, possibly due to an insufficient power supply.
Measuring the 5V on the Pi (when you see the blinking) would be interesting.

A better HDMI cable may imrpove the issue.
Adding config_hdmi_boost=7 (can be increased up to 11) to config.txt may also help.

1 Like

I tried a power supply from my iPad (it has 2.4A), but that didn’t help, so I ordered a 3A power supply. Today it finally arrived, but unfortunately it didn’t solve the problem either. The situation got a bit better, but still screen is blinking and dropping.

However, I tried to use config_hdmi_boost=7 in config, and I got a bit more stable picture. Then I tried 9, but still it was not good enough, so I set it to 11, and now I have perfectly stable picture, no more blinks. I should have start with this instead of waiting for a new power supply :slight_smile:

However, naturally I have a question: how bad is it if my RPi Zero W will work with config_hdmi_boost=11 all the time? I mean, it’s rarely recommended to use anything at its maximum capabilities.

At a guess I’d say you have a poor quality (or unusually long) HDMI cable.
The config_hdmi_boost parameter compensates for that by boosting the signal.

Given that 9 wasn’t enough and 11 works then the signal the TV is receiving won’t be too high and you will be fine.
But, if you do change the HDMI cable or the display, then it’s probably best to remove that setting.
(although we’ve never heard a report of any problems resulting from boosting the signal).

1 Like

Well, goddamnit. Just for the sake of experiment I’ve tried it now with another HDMI cable, having disabled the boost - and it works fine. For more than a month I couldn’t have just tried to replace the HDMI-cable, what’s wrong with me.

Thank you for your help!