RPI1-b model CEC issue

Hi all!

Been using RC for some days now, and every time I switch to the RPi it crashes and restarts OSMC (not a full device reboot) and it gives an error about CEC. Tried deleting the CEC settings but no luck there.
Tried new cables, different HDMI ports, etc.

Last worked on Alpha 3, was hoping it’d fix itself in a future release but sadly it didn’t.

Where do I go from here?

Thanks in advance!

Best regards,

Rick Kramer

A debug log will help us get to the bottom of the problem

Sam

[logs removed]

That’s it… Hope you can help :slight_smile: Thanks Sam!

PS: using hdmi_force_hotplug=1 stops generating these errors, but the TV (Samsung Smart TV) says the Anynet+ device cannot be connected even though it’s listed in the devices and inputs.

Please use http://paste.osmc.io or similar to provide full and complete debug logs instead of posting long snippets in a forum post without using code tags. Alternatively, the log uploader feature within MyOSMC addon can “Upload all logs” and give us a much better picture of anything that might be involved.

Pastebin OSMC

If more logs are needed, let me know.
And @ActionA, sorry, didn’t know how you guys want to receive logging :wink:

1 Like

This is a simple Kodi log. Can you please create a debug log and use the log uploader (include all logs please) as described here https://osmc.tv/help/wiki/logs to provide some more detailed info?

http://paste.osmc.io/udiqotifes
Thats the debug log hopefully :blush:
Thanks ActionA

Found out it’s an issue with my IPTV set top box, when it’s connected to the TV CEC stops working for my RPi sadly. Is it anything that can be fixed maybe?

i have the same with a freeview box – do you have a samsung tv?

Yep, Samsung UE46D6500…