RPI2 crash to sad face after trying to install addon or repository

Hi, I have RPI2 and I’m using OSMC 16.0
Recently, I noticed some problem after this upgrade. One of my RPI just crash in loop and when going to log file, I can see it Kodi trying to load some addons and repositorys that are not working anymore. After removing these addons and repositories, KODI become stable again.
I have the same problem on another of my RPI2 with OSMC.
Also, now when I try to install some new addon or repository in ZIP format. Some installations make it crash to SAD face.
Anyone having same problem? Would like to make KODI stable again please.

Thanks in advance.

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Ok thank you.
Here is my log with debug on:
enter link description here

Thanks in advance for your help!

I’m not looking through x amount of pages.
Just use the log uploader within the My OSMC menu and post the link here.

I enabled everything. hope its not too much.
http://paste.osmc.io/juvikeqohe

Thanks again

mv .kodi kodi.backup

then reboot kodi.

Ok, by doing that, I have a brand new Kodi and the addon and repository that I was trying to install, now install well.
But it’s kinda suck that I will lose all my settings, addons, themes, etc.
But now I know it’s not KODI or OSMC, but some others addons that make it crash.

Thank you guys!

Stop kodi with sudo systemctl stop mediacenter

overwrite ~/.kodi/userdata/guisettings.xml with ~/kodi.backup/userdata/guisettings.xml

start kodi with sudo systemctl start mediacenter

1 Like