RPi2 mpeg2 license key not kept in config.txt

I installed the OSMC july release and whatever way I try to enter the mpeg2 license it is lost after reboot.
I tried OSMC GUI and directly adding it to /boot/config.txt. The file is alwyays modified by root with a timestamp newer than the one from my edit.

I am coming from Openelec and there the same keys work in the same format:

Any suggestions to resolve this are highly appreciated.


So far, I’ve been in the habit of setting it from the command line by editing config.txt.

You are the only report of such an issue that I’ve seen in OSMC. Either you aren’t selecting a “save” or “apply” option in MyOSMC after entering or you are doing something else wrong. If you use MyOSMC, I believe you only have to enter the XXXXXXXXXXX key itself, the addon adds the “decode_MPG2” portion. I’m not in front of my pi today to confirm but maybe worth a try.

thank you both, it’s the first time I am encountering such issue. I tried both methods you mentioned many times and before reboot the license strings are visible in config.txt every time. After the reboot they always disappear.

I probably should just re-install osmc…

Obvious next step, if you haven’t already tried it, is to shut down the Pi system, extract the SD card, get it where another system can read it, and edit the config.txt there.
Boot up again - and all should be OK.

OK, this works now. I used Disk Imager to read the current sd card and wrote it back to a new. So there was some kind of corruption.

Thanks everyone

Same issue here. After poking around it seems the config.txt file isn’t writeable from within osmc, per ssh I was able to edit the file. I have no idea why the MyOSMC doesn’t work though. ALL my changes in the MyOSMC remain unwritten (settings, overclocking etc.).
OSMC was installed on a USB stick (/sda1) automatically which was connected to the RasPi on first boot.
The /boot is on the SD card (/dev/mmcblk0p1). The ‘mount’ command reveals an option ‘errors=remount-ro’ for the /boot entry. Does this mean there was an error while booting and /boot was mounted ro?
Nevertheless am I able to write to /boot per ssh.

You might be impacted by this bug Pi Config not saving settings - #24 by bfqrst

Yes, thanks, problem solved!

To edit config.txt and to have the changes survive a reboot, ssh into your RasPi and remount the /boot directory as read-write:
sudo mount -o remount,rw /boot

Then edit config.txt and append your MPEG-2 license to the end of the file:
sudo nano /boot/config.txt

As OP mentioned, the line to add at the end of config.txt will be in the format of decode_MPG2=xxxxxxxxxx

Hit CTRL-O to save the new config, hit CTRL-X to exit nano.

Reboot your RasPi by typing reboot and you’re good to go.

To verify that config.txt has saved your changes, after reboot ssh back into your RasPi and cat /boot/config.txt | grep "decode"
You should see your MPEG-2 license displayed.