RPi2, RC3, Profiles can't stream from Video Add-ons

Raspberry Pi 2
SanDisk Ultra 64 GB

If I just use the default master account everything works as expected.

When I create a new Kodi profile (Default folder location, separate media info and sources) and login as that profile, no video add-ons will stream. I can browse through the TED Talks or the Youtube videos, or my Emby collection, but when I select an item to play the “Working” popup appears for a bit and then disappears and the video doesn’t play. Sometimes if I try to select another item it will popup with a “Failed to play” message, or something of that nature. This also effects PVR plugins. I can see the channels and EPG, but cannot play anything, it just says it failed to connect (works fine with default master profile).

I have also noticed that I cannot “Get Add-ons” as these profiles, only as the master… After selecting the repository the list is blank for the profiles.

Just for comparison, I installed Kodi Helix on my Windows PC and setup the profiles the same way. They worked as expected. PVR worked, Emby worked, other video add-ons worked.

It seems like it may not be just OSMC though, I tried the latest build of OpenELEC with the same results as with OSMC…

Is there some sort of config change or permissions I need to assign for Kodi profiles to work properly?

This was an issue that has been fixed: [RBP] Fix for cachemembuffersize initialisation and multiple profiles · popcornmix/xbmc@60babac · GitHub
Possibly there hasn’t been an updated build since them. It should be fixed in a future build.